1. 1990 Jeep Grand Wagoneer ignition problems

    Hello all my names Wil I own a 1990 jeep grand Wagoneer,

    I've been having a very strange problem with my Wagoneer, when I crank it over for the first turn I will get exactly (pretty inconsistently) one spark and nothing more until I stop running the starter and then I will get one more spark, I've done these tests directly from the coil everything seems to be hooked up right and it was running but after the battery died this is all I get I checked the fuseable links but there all good and checked the wire I'm using to test the coil and it worked fine and then I purchased a new coil put it in and same thing, I'm just very confused, any help is super appreciated just frustrated a little, hoping for someone to help.

    Thanks,
    Wil

  2. #2
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    6,158

    Re: 1990 Jeep Grand Wagoneer ignition problems

    So you verified you get one plug to spark once during start?
    Or the engine sounds like it fires once on the first crank?

    Did you verify fuel pressure?
    Air? Nothing blocked or carboned up?
    Other than that timing being off.

    Air ,fuel, and spark


    Never look down on anyone unless you are helping them up - Jesse Jackson
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  3. #3

    Re: 1990 Jeep Grand Wagoneer ignition problems

    Update I have taken one spark plug out turned over the car and got no spark, when I tested the coil from the positive terminal of the coil 6.48 volts (is that normal???) I also checked the negative side of the coil and got 1.55 volts I'm not sure if that's normal or not, I had timed the car before the problem occurred and the car ran very well until this, if I unplug the two wires (ones green ones yellow) running to the ignition control unit I get 12.33 to the positive terminal and same on the negative terminal, its possible the ICU (Ignition Control Unit) is possibly faulty but its strange because its brand new same with the distributor and the coil but it started 6 times over one day after draining the car of all power and then reconnecting the battery but also ran very rough. I'll list all new parts (new distributor, ignition coil, ICU) Help once again is appreciated. thanks, Wil
    Last edited by 1990JeepWagoneer; 09-11-2021 at 09:08 PM.

  4. #4

    Re: 1990 Jeep Grand Wagoneer ignition problems

    Ok sure enough it was the Ignition Control Unit, replaced it and the Wagoneer runs like a dream.

    Thanks.

  5. #5

    Re: 1990 Jeep Grand Wagoneer ignition problems

    good deal
    99 xj with 350k miles on it. Still runs great

  6. #6
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    6,158

    Re: 1990 Jeep Grand Wagoneer ignition problems

    Awesome! Feels good to figure it out yourself. Enjoy the weekend.


    Never look down on anyone unless you are helping them up - Jesse Jackson
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

Similar Threads

  1. 87' Grand Wagoneer Ignition problems
    By underapew in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 12
    Last Post: 01-20-2017, 01:16 PM
  2. Replies: 0
    Last Post: 02-03-2010, 12:07 PM
  3. Turn Signals/Blinkers not working on my 1990 Grand Wagoneer
    By Jameson in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 0
    Last Post: 11-07-2008, 11:24 PM
  4. headers for 1990 grand wagoneer?
    By Tug-n-pull in forum All other Jeep models
    Replies: 2
    Last Post: 07-20-2003, 08:00 PM
  5. 1990 jeep grand wagoneer transfer case
    By cherokee_kid in forum All other Jeep models
    Replies: 1
    Last Post: 07-20-2003, 08:00 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in