Thread: cold start

  1. cold start

    in the morning when I start my truck during the cold start it makes like a piston slapping sound for about 10 seconds then it goes awayI've been trying to figure out what it is so I can get the problem fixed anybody have any idea I'm thinking it could be my oill pump or my piston skirts idk

  2. #2
    Join Date
    Nov 2014
    Location
    Edmonton,Alberta, Canada
    Posts
    104

    Re: cold start

    Does it do this at any other time? Why do you suggest the oil pump, is pressure low? Have you narrowed it to the bottom end? Suggested piston slap, hear more from the top end? If you think piston, a compression test would give you more of an idea as far as maybe rings and valves condition. You getting oil passing or burning? if a tap is coming from your lash adjusters, it can be pretty difficult to pin point. Have a listen through the exhaust and see if there is any weird rattles or your slapping sound.What about the timing chains, tensioner, can get weak and chain can slap.And put it out of time if it jumps. I would try and get an ear in there and maybe you can get a better idea of where it's coming from

  3. #3

    Re: cold start

    Quote Originally Posted by drewbuddy View Post
    Does it do this at any other time? Why do you suggest the oil pump, is pressure low? Have you narrowed it to the bottom end? Suggested piston slap, hear more from the top end? If you think piston, a compression test would give you more of an idea as far as maybe rings and valves condition. You getting oil passing or burning? if a tap is coming from your lash adjusters, it can be pretty difficult to pin point. Have a listen through the exhaust and see if there is any weird rattles or your slapping sound.What about the timing chains, tensioner, can get weak and chain can slap.And put it out of time if it jumps. I would try and get an ear in there and maybe you can get a better idea of where it's coming from
    done

  4. #4

    Re: cold start

    Quote Originally Posted by j gonzalez View Post
    done
    I'll have a compression check done and have my timing looked at and it only does it when the trucks been sitting all night and is cold I didn't do it this morning when I started it but every once in awhile it makes a loud clanking noise and misfires for about 3 or 4 seconds maybe 10 seconds and then it stops after the truck warms up and I noticed during the summer time when I would let the truck sit for about 2 or 3 days without starting it when I finally started it does the same thing thanks for the input I'll check things out and let you know how it goes thank you

Similar Threads

  1. Very cold starting
    By griff in forum Wrangler and CJ
    Replies: 7
    Last Post: 04-14-2005, 06:08 PM
  2. Cherokee cold starting questions.
    By JimGJr in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 1
    Last Post: 12-28-2004, 09:50 PM
  3. Cold Start Problems and Backfire from Weber Carb
    By DavidRGallagher in forum Wrangler and CJ
    Replies: 1
    Last Post: 03-13-2004, 11:53 PM
  4. Cold starts
    By 93bizzleYJ in forum Wrangler and CJ
    Replies: 2
    Last Post: 12-02-2003, 10:21 PM
  5. Replies: 1
    Last Post: 07-20-2003, 07:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in