1. Transmission over temp issue...is back again, help?

    Hello,

    2 weeks ago, on the first really sunny hot day of the year, as I was driving on the highway after 50km, the dreaded Transmission over temp message rang in the electronic dashboard..it felt like something hit me right in the head. I hate it. It causes panic.

    I had this issue on hot summer days last year and eventually bought an infrared heat gun off amazon or ebay as suggested by others to see if the transmission oil is really hot. When I bought it, it never occurred again as Fall had just begun and it never really got hot again. It did not occur all winter either.

    When it last happened 2 weeks ago, I pulled over, looked and felt the transmission oil, all seemed normal, it was not hot. I went to the dealer and explained him all this, and one of the managers there said to ignore it after asking me questions.

    We had performed a bunch of stuff last year such as cleaning some parts but it seemed to not have helped. I also started receiving this message a few days after I had performed a terrible boost on my friend's car which drained my battery. I than had to get it recharged... I'm just wondering if that caused all this...

    What would you guys do? Also, where does one point that infrared gun exactly? I have a 2006 Laredo 4.7 V8.

    Thanks!

  2. #2
    Join Date
    Dec 1999
    Location
    Virginia Beach VA
    Posts
    8,000

    Re: Transmission over temp issue...is back again, help?

    I don't have the answer to your problem, other than to say make sure that your transmission filter has been changed, and the fluid is fresh. Once the fluid has been overheated / burnt, it needs to be replaced.

    My Wrangler transmission would go overtemp when offroading, so I installed an additional transmission cooler. It seemed to help:
    http://www.jeepz.com/forum/engine/40...r-install.html (Transmission cooler install)

    If I had to guess where you should take the temperature, I'd say the transmission pan, on the bottom of the transmission.
    My 2005 Wrangler Build Thread

    “He who is without oil shall throw the first rod.” -Compressions 8.7:1

  3. #3
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    5,156
    What ^^he^^ said. If your fluid is brown change it and the filter.


    Post "boost" or jumping another vehicle should not effect yours, if done correctly. It should not drain your battery. Get your battery load tested and clean terminals and connectors. Clean grounds as well. A low charged battery or charging issue will cause strange things in the electrical system including CEL lights for low sensor voltages.


    Number 1 issue is battery and connections.


    I kind of feel like a skipping record on battery and ground connections, but it is true and the cheapest fix out there.
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

Similar Threads

  1. Transmission over temp message help
    By laredo2006 in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 16
    Last Post: 08-03-2014, 09:02 PM
  2. Jeep Grand Cherokee Laredo - 2008, warning light & transmission over temp message
    By jijoyattitude in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 0
    Last Post: 09-18-2012, 08:57 AM
  3. my latest purchase! (dingus is BACK) (carb help?)
    By dingus in forum General Chat
    Replies: 12
    Last Post: 12-22-2003, 09:14 AM
  4. My jeep is back on the road but it doesn't like it
    By Jeepster05 in forum General Chat
    Replies: 7
    Last Post: 07-20-2003, 07:00 PM
  5. Drivetrain Fluid Question, Tug is Lazy please help!
    By dingus in forum Wrangler and CJ
    Replies: 13
    Last Post: 07-20-2003, 07:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in