1. #1
    lunchbox07's Avatar
    lunchbox07 is offline Junior Member
    Join Date
    Jan 2012
    Posts
    18

    No power to fuel pump or gauges

    98 cherokee sport. It started just fine the other night ran back inside for a minute and it had died. Now it wont start. All it does is crank over but wont start. Fuel pump is not kicking on so it may be that. But what we cant figure out is why the gauges wont work when im key is in on position. So it sounds like im not getn power somewhere. My question is, is there anything that ties the fuel pump and gauges preventing them to not work??? Need help so I dont change pump if I dont have to.

  2. #2
    SteelHeadz's Avatar
    SteelHeadz is offline Moderator
    Join Date
    Oct 2008
    Location
    Kerrville, TX
    Posts
    6,087

    Re: No power to fuel pump or gauges

    My first thought would be checking all the fuses under the hood and inside the cabin. Does the cluster have a digital odometer?, if it does, does it display "no bus"?. If it does, check your connections on the ECU/PCM and verify that there is no corrosion, bad connnections, pulled out pins and or fretting in the pins. Is there a DTC(Check engine light on)?, if there is, get it scanned and see what the dtc is. Check the ignition switch connectors and verify that the run position has 12volts with key on. My guess at this point would be either crank sensor or pcm however, the crank sensor would not always knock out the gauges unless it's a short to ground on the sensor circuit but it will prevent the fuel pump from energizing if the pcm does not see a reference on the ignition timing.
    Confucious says: Don't eat the snow where the huskies go!

  3. #3
    lunchbox07's Avatar
    lunchbox07 is offline Junior Member
    Join Date
    Jan 2012
    Posts
    18
    Started with the fuses and fuel relay and they were ok. Ill check those others out.

  4. #4
    lunchbox07's Avatar
    lunchbox07 is offline Junior Member
    Join Date
    Jan 2012
    Posts
    18
    Fuel pump still works. Found that out by taking the relay apart and played with it to see if the pump kicks on. It did. So theres no power signal from ignition to relay. So guna try a new ignition tomorrow.
    Last edited by lunchbox07; 06-25-2012 at 11:28 PM.

Similar Threads

  1. Power steering pump went out
    By extra-medium in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 3
    Last Post: 12-24-2011, 10:42 AM
  2. power to the yj fuel pump question
    By tailights24 in forum CJ YJ TJ and JK
    Replies: 2
    Last Post: 02-16-2011, 07:47 AM
  3. Need help asap!!!! New fuel pump, fuel gauge intermittenly works now
    By titus90703 in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 2
    Last Post: 08-28-2010, 05:59 PM
  4. help, no power to fuel pump/injectors
    By mcgbail in forum CJ YJ TJ and JK
    Replies: 8
    Last Post: 02-10-2009, 08:47 PM
  5. Power Steering Pump
    By LauraBoston in forum CJ YJ TJ and JK
    Replies: 7
    Last Post: 11-19-2003, 04:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in