Page 1 of 3 123 Last
  1. #1
    Elheffa's Avatar
    Elheffa is offline Member
    Join Date
    Feb 2017
    Location
    Deep south texas
    Posts
    50

    93 jgc 4.0 running rough

    Hello all i have a 93 grand cherokee 4.0L and have been doing work to it running down problems that i have noticed and seems the more i fix the more i find that needs fixed but am having problems figureing out my current problems and looking for a little help pointed in right direction

    I had several oil leaks i have fixed rms, oil adapter elbow and valve gasket and seemed they dont leak anymore but durring the repairs the jeep has had a rough idel when coming up to stops to the point it acts like it is going to stall out dropping to about 250-300 rpm befor it goes back up to 500 was loseing a lot of oil from leaksand geting blue smoke a lot on start up then tones down so i replaced the valve stem seals and only smokes a little blue smoke at startup now but the problem i am now having is it takes what seems like forever to gain speed past 45mph takes me about 3 miles to get from 45-65mph and when i have a wall next to me it sounds loud almost like an air compressor with nothing on it just blowing air everything i have replaced on it has been factory installed the engine currently has 203k miles on it but this new problem is something i really need to fix and seems my valve seals when replaced just gave me the symptoms of the real problem

    Any suggestions

    I am thinking of replaceing piston rings and seals/gaskets on everything i remove is this my best bet

  2. #2
    Elheffa's Avatar
    Elheffa is offline Member
    Join Date
    Feb 2017
    Location
    Deep south texas
    Posts
    50

    Re: 93 jgc 4.0 running rough

    Also i have not had a cel light or any engine codes pop up

  3. #3
    superj's Avatar
    superj is offline Senior Member
    Join Date
    Feb 2010
    Location
    texas
    Posts
    5,690

    Re: 93 jgc 4.0 running rough

    Vacuum leak? Maybe the catalytic converter is partially clogged?
    almost done with all the yj stuff.

  4. #4
    Elheffa's Avatar
    Elheffa is offline Member
    Join Date
    Feb 2017
    Location
    Deep south texas
    Posts
    50

    Re: 93 jgc 4.0 running rough

    All new vac lines connectors and so on, new exaust from header connection to tail pipe as when i got jeep it was rusted and had a few holes in it, most everything besides engine and drivetrain has been replaced since i bought it

  5. #5
    superj's Avatar
    superj is offline Senior Member
    Join Date
    Feb 2010
    Location
    texas
    Posts
    5,690

    Re: 93 jgc 4.0 running rough

    Where are you at? I know some people here in corpus who might have some ideas
    almost done with all the yj stuff.

  6. #6
    JPNinPA's Avatar
    JPNinPA is offline Senior Member
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    3,511

    Re: 93 jgc 4.0 running rough

    Check your fuel pressure. At idle and at like 3-3.3K rpm.
    O2sensors? Are they OEM? Even though the exhaust is new you could still have a leak at a connection.
    Intake leak? What rom do you idle at?

    Does the engine feel sluggish like the pedal is doing nothing? Dirty TPS causes flat spot(s) in the pedal.


    Regards,
    JPNinPA

    Sent using TapTalk
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  7. #7
    Elheffa's Avatar
    Elheffa is offline Member
    Join Date
    Feb 2017
    Location
    Deep south texas
    Posts
    50

    Re: 93 jgc 4.0 running rough

    Im in los fresnos

    The cps is new just replaced not to long ago due to random dieing wile driving

    Fuel pressure is normal just had that checked by a friend but he cant figure the problem out

    O2 sensors are still factory so assuming oem

    The only thing not new on exaust is manifold and going to check that now (would a leak at manifold cause rough idel and power loss?) No leaks from manifold back as have checked it first off only 4 welds on whole new exaust system 2 at cat on eather side and 2 on muffler at eather side and all are good

    As startup it idels at 1000 rpm and drops to 500 after a few mins of warmup only time it drops below 500 is when i come up to stops and almost bogs out and feels like its going to die but picks up 2-3 seconds later

    Gas pedal is extreamly responsive small tap and engine revs right up

  8. #8
    Elheffa's Avatar
    Elheffa is offline Member
    Join Date
    Feb 2017
    Location
    Deep south texas
    Posts
    50

    Re: 93 jgc 4.0 running rough

    Ok just checked my exhaust manifold and where the 2 pipes meet and go into 1 it feels like how the tail pipe should feel. going to repair and see if it solves the problem and if it dose will replace with a new one will post my results tomorrow after i fire it up and test run it

  9. #9
    superj's Avatar
    superj is offline Senior Member
    Join Date
    Feb 2010
    Location
    texas
    Posts
    5,690

    Re: 93 jgc 4.0 running rough

    your idle issue is a dirty idle control valve. you can take it out of the throttle body and clean it with carb cleaner. just spray it till its clean and then spray in the throttle body till its clean, also. that's a very common 4.0 issue. once you do that, your low idle issue with disappear. but, when you are cleaning it, don't try to pull the tip of it or try and spin it, it will break easily (I found out). its the other thing with wires on it on the throttle body, nearest the valve cover side
    almost done with all the yj stuff.

  10. #10
    paradineai's Avatar
    paradineai is offline Member
    Join Date
    Jan 2017
    Location
    Peoria, IL
    Posts
    40

    Re: 93 jgc 4.0 running rough

    I agree with super but you will also want to check your mass airflow sensor. This is the part on your intake tube between the filter and throttle body, with the wires connected to it.

    Sent from my SM-J320V using Jeepz.com mobile app

  11. #11
    superj's Avatar
    superj is offline Senior Member
    Join Date
    Feb 2010
    Location
    texas
    Posts
    5,690

    Re: 93 jgc 4.0 running rough

    I don't think her 93 will have a mass air flow sensor, unless I am just blanking it out of my memory. the intake tub goes from the tb to the filter with no wires to anything

    almost done with all the yj stuff.

  12. #12
    paradineai's Avatar
    paradineai is offline Member
    Join Date
    Jan 2017
    Location
    Peoria, IL
    Posts
    40

    Re: 93 jgc 4.0 running rough

    I forgot they moved it from throttle body to tube in 99

    Sent from my SM-J320V using Jeepz.com mobile app

  13. #13
    paradineai's Avatar
    paradineai is offline Member
    Join Date
    Jan 2017
    Location
    Peoria, IL
    Posts
    40

    Re: 93 jgc 4.0 running rough

    It should be sensor on throttle body furthest from valve cover directly below the intake tube.

    Sent from my SM-J320V using Jeepz.com mobile app

  14. #14
    je4reyk's Avatar
    je4reyk is offline Junior Member
    Join Date
    Feb 2011
    Posts
    26

    Re: 93 jgc 4.0 running rough

    It still sounds like a plugged exhaust,my 88 xj exhaust system was plugged it would be ok around town but anything over 30 mph it was a dog .
    Do a compression test that will tell a lot

    Sent from my SM-G935V using Jeepz.com mobile app

  15. #15
    je4reyk's Avatar
    je4reyk is offline Junior Member
    Join Date
    Feb 2011
    Posts
    26

    Re: 93 jgc 4.0 running rough

    The sensor they're talking about is the one on the firewall just above the valve cover on the divers side ,check the vacuum line from there to the throttle body,and the wires that are plugged into it

    Sent from my SM-G935V using Jeepz.com mobile app

  16. #16
    Elheffa's Avatar
    Elheffa is offline Member
    Join Date
    Feb 2017
    Location
    Deep south texas
    Posts
    50

    Re: 93 jgc 4.0 running rough

    Both sensors are cleaned off and still same problem taking it in tomorrow for a compression test and maybe a digonistic

  17. #17
    je4reyk's Avatar
    je4reyk is offline Junior Member
    Join Date
    Feb 2011
    Posts
    26

    Re: 93 jgc 4.0 running rough

    Was this thing getting bad gas mileage before,and how long ago did the cat get changed. Was it running rich ?
    What temp thermostat is in it?

    Sent from my SM-G935V using Jeepz.com mobile app

  18. #18
    Elheffa's Avatar
    Elheffa is offline Member
    Join Date
    Feb 2017
    Location
    Deep south texas
    Posts
    50

    Re: 93 jgc 4.0 running rough

    Getting areound 15.8mpg on avarage thermostat runs right below 210 mark dead smack in middle of gauge since day i got it not sure what temp thermostat as have never changed it due to no noticable differance in temp fluctuations

    Dont know if it was running rich or lean as was getting a little oil in cylinders from valve stem seals that i just fixed ill upload a pic of sparks befor and after stem seal replacement

  19. #19
    Elheffa's Avatar
    Elheffa is offline Member
    Join Date
    Feb 2017
    Location
    Deep south texas
    Posts
    50

    Re: 93 jgc 4.0 running rough

    93 jgc 4.0 running rough-20170213_221505.jpg

    Before

    93 jgc 4.0 running rough-20170213_222014.jpg

    After and been running for about 1 week same as the before pic

    Sent from my SM-G930T using Jeepz.com mobile app

  20. #20
    Elheffa's Avatar
    Elheffa is offline Member
    Join Date
    Feb 2017
    Location
    Deep south texas
    Posts
    50

    Re: 93 jgc 4.0 running rough

    Uploaded wrong pic of the befor that was 3 months run time

    93 jgc 4.0 running rough-1487047140454.jpeg

    Thats a 1 week runtime

    Sent from my SM-G930T using Jeepz.com mobile app

Page 1 of 3 123 Last

Similar Threads

  1. running rough
    By bluejeeper in forum CJ YJ TJ and JK
    Replies: 2
    Last Post: 02-03-2011, 07:17 AM
  2. Running rough
    By black94yj in forum CJ YJ TJ and JK
    Replies: 5
    Last Post: 03-11-2010, 02:37 PM
  3. running rough
    By 87YJNUBE in forum CJ YJ TJ and JK
    Replies: 2
    Last Post: 08-12-2009, 07:02 AM
  4. yj rough running HELP!!!!!
    By Rcwarrior in forum CJ YJ TJ and JK
    Replies: 12
    Last Post: 05-22-2006, 09:17 PM
  5. rough running TJ
    By ZBTstang in forum CJ YJ TJ and JK
    Replies: 6
    Last Post: 07-20-2003, 07:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in