1. #1
    oldmanXJ's Avatar
    oldmanXJ is offline Junior Member
    Join Date
    Sep 2017
    Posts
    2

    1990 XJ missing problems

    Ive got a 1990 Xj that is doing funny shit.
    ive recently replaced the plugs, wires, distributor rotor and cap, IAC valve. every one of the parts ive replaced have made the jeep run better for about a week. then back to sputtering. the sputtering is inconsistent. cold motor, hot motor, sometimes not at all. sometimes only when I hit bumps????? was thinking electrical issues but maybe gas related.
    Please Help love my Jeep

  2. #2
    k-2's Avatar
    k-2
    k-2 is offline Senior Member
    Join Date
    Apr 2017
    Posts
    261

    Re: 1990 XJ missing problems

    Guessing A 6cylinder?

    Do basics -
    fuel pressure use gauge. Then KOEO watch pressure drop ie drops Xpsi in 5min/
    Check for vacuum leaks.
    Spark at all plugs

    Plugs wet, dry, black,tan?

  3. #3
    k-2's Avatar
    k-2
    k-2 is offline Senior Member
    Join Date
    Apr 2017
    Posts
    261

    Re: 1990 XJ missing problems

    try this for a code ck

  4. #4
    JPNinPA's Avatar
    JPNinPA is offline Senior Member
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    3,675

    Re: 1990 XJ missing problems

    Does the PCM throw a CEL or does it blink?
    Clean the battery terminal and connectors.
    Clean the opposite end of the grounds.
    Check for vacuum leak by spraying around the intake and vac lines.
    Check fuel pressure off, idle and at rpm
    What did your old plugs look like?



    Regards,
    JPNinPA

    Sent using TapTalk
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  5. #5
    oldmanXJ's Avatar
    oldmanXJ is offline Junior Member
    Join Date
    Sep 2017
    Posts
    2

    Re: 1990 XJ missing problems

    looks like ill have to get those lights to work first

  6. #6
    superj's Avatar
    superj is offline Senior Member
    Join Date
    Feb 2010
    Location
    texas
    Posts
    5,734

    Re: 1990 XJ missing problems

    I bet its a wiring issue. like a bump or a shift in the wires makes it run bad.
    no more jeeps at this time. next time it will be a cj with a v8

Similar Threads

  1. Missing IAC
    By gbclowes in forum CJ YJ TJ and JK
    Replies: 2
    Last Post: 04-18-2014, 09:31 PM
  2. Missing In Action
    By stumblnyj in forum General Chat
    Replies: 0
    Last Post: 11-13-2012, 05:56 PM
  3. Am I missing something here? or am I just getting too old?
    By Turbogus in forum CJ YJ TJ and JK
    Replies: 13
    Last Post: 08-23-2012, 04:06 PM
  4. 1990 cherokee abs problems
    By imderrick247 in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 1
    Last Post: 01-16-2009, 08:27 PM
  5. Am I missing something??
    By Jason4x4 in forum CJ YJ TJ and JK
    Replies: 4
    Last Post: 01-10-2008, 06:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in