1. #1
    DJM's Avatar
    DJM
    DJM is offline Junior Member
    Join Date
    Jun 2019
    Posts
    3

    2004 Jeep Grand Cherokee Laredo, alternates running great with running rough

    I'm just the driver, so I will be relaying all suggestions to my mechanic .... My jeep can run perfect one trip to work / one entire day and then be mildly to horribly rough running the next day.
    On the trips/days it is destined to act up, it starts out running just fine. I sometimes think there is some correlation between driving higher speeds on rough highway as to when it starts to act up.
    The rough running is most often between 50-65 mph, but not limited to that range. These last couple of days lower speeds have been an issue too. If I can take my foot off the gas and coast, it almost always goes back to running perfect, altho since it has started acting up at lower speeds, it can idle a bit rough too. Also if I can give it a whole lot more gas and drive a lot faster, it usually runs much less rough. When it's acting up, it has less power (hills / take offs / corners), and gas mileage drops to a depressing 10.5 mg. Now if I have to really put my foot into the gas pedal to get it up to speed, it may shift harder and spew black smoke. It will then go faster and then seconds later have an extra burst of speed without any additional pressure on the gas pedal. Oh, and sometimes the CE light is on (always says an O2 sensor which we replaced) and other times it is not, regardless of how it is running.

    Over the time we've spent trying to resolve these issues, it has slowly gotten worse and the problems more pronounced. Here is what's been done:
    I added a bottle of Heet, Water remover and injector cleaner to a full tank of gas which seemed to work.
    When the problem returned on the next full tank of gas, I added another. Did not help this time.
    new O2 sensor
    replaced coil pack
    replaced injectors
    checked for vacuum leaks
    replaced a ground wire
    checked connections
    unplug / re-plug the computer (may or may not make any difference)

    This weekend's game plan is to go thru all the wiring with a fine tooth comb. Any suggestions will be greatly appreciated
    Last edited by DJM; 06-20-2019 at 12:06 PM. Reason: forgot one thing we've tried

  2. #2
    JPNinPA's Avatar
    JPNinPA is online now Senior Member
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    4,668

    2004 Jeep Grand Cherokee Laredo, alternates running great with running rough

    That black cloud you mention may be your CAT clogging up. Hence the O2 sensor code.

    Check your plugs for burning oil or running rich. Might even be a stuck exhaust valve.

    I will always suggest cleaning the TB and IAC. And ask if it is the pedal position or the speed/load you are at when it acts up.
    Regards,
    JPNinPA

    Sent using TapTalk
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  3. #3
    DJM's Avatar
    DJM
    DJM is offline Junior Member
    Join Date
    Jun 2019
    Posts
    3

    Re: 2004 Jeep Grand Cherokee Laredo, alternates running great with running rough

    Thank you for the suggestions, I will pass them on to my mechanic.

    as for pedal position speed / load, there does seem to be some consistency, but not always. I've not been going too far from home with it,
    say 30 miles max since it's been having these issues. There are days when it runs great to and from my destination. Other days it might run
    rough getting me where ever, but run great all the way back home. On trips when it acts up, it usually starts off great. Then it either seems like a
    distance of about 8-10 miles is when it starts to act up, or if I'm driving over a crappy rough road that sometimes seems to start making it act up,
    or sometimes it seems to relate to once I am on a highway and wishing to keep a steady speed between 50-65 mph. Taking my foot off the pedal
    and coasting smooths it out, or giving it a whole lot more gas, makes it run a bit less rough. Now lately tho, its sometimes been giving me some trouble at
    slower speeds too and in this case, taking my foot off the gas does not make it run smooth again.
    slower speeds too,

  4. #4
    JPNinPA's Avatar
    JPNinPA is online now Senior Member
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    4,668

    Re: 2004 Jeep Grand Cherokee Laredo, alternates running great with running rough

    Ok another idea, the O2 was changed. Jeeps are finicky about O2. Did you put a oem brand O2 sensor
    in?
    What was the code you were getting?


    Sent from my iPhone using Jeepz.com mobile app
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  5. #5
    DJM's Avatar
    DJM
    DJM is offline Junior Member
    Join Date
    Jun 2019
    Posts
    3

    Re: 2004 Jeep Grand Cherokee Laredo, alternates running great with running rough

    I'll ask mechanic which brand he put on it and what the codes were. I dropped it off on my way home as he plans to spend Saturday working on it. Fingers are crossed.

  6. #6
    JPNinPA's Avatar
    JPNinPA is online now Senior Member
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    4,668

    Re: 2004 Jeep Grand Cherokee Laredo, alternates running great with running rough

    Any luck?


    Regards,
    JPNinPA

    Sent using TapTalk
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

Similar Threads

  1. 2004 Jeep Grand Cherokee laredo interior lights, locks and windows repair
    By josh83 in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 1
    Last Post: 06-28-2017, 06:33 PM
  2. Cherokee Country running rough...
    By JamesTheScot in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 3
    Last Post: 03-01-2011, 12:06 PM
  3. 95 Grand Cherokee running ROUGH
    By Jeepmamma in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 2
    Last Post: 06-28-2009, 10:18 AM
  4. 91 jeep running rough
    By lgbent in forum CJ YJ TJ and JK
    Replies: 11
    Last Post: 01-29-2007, 05:43 AM
  5. my Jeep is running rough! Check engine light is on.....
    By Tug-n-pull in forum CJ YJ TJ and JK
    Replies: 12
    Last Post: 07-20-2003, 07:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in