1. #1
    Branjmb's Avatar
    Branjmb is offline Member
    Join Date
    Aug 2010
    Posts
    66

    YJ starting problem help!!!

    ok, just finished putting a new 4banger in my jeep, and a new starter.

    When I turn the ignition the battery/accessories come on, the engine turns over, and you hear this clicking noise- mechanical not electronic. the first time it happened we thought the starter was not properly engaged, but then we got it to start, and it ran for 15 minutes.

    It's doing it again today, after letting it run those 15 minutes we called it a night, so I thought it might be the battery (wasn't thinking clearly this morning).... so i jumped the car with my dad's TJ.... same problem

    any ideas??

    just a bad starter maybe??
    Jeep Wrangler '92 YJ

  2. #2
    Branjmb's Avatar
    Branjmb is offline Member
    Join Date
    Aug 2010
    Posts
    66

    Re: YJ starting problem help!!!

    Update!! I just went to an autoparts store and they tested the brand new starter.... and it works fine.

    what else could it be??
    Jeep Wrangler '92 YJ

  3. #3
    TLCJ5's Avatar
    TLCJ5 is offline Senior Member
    Join Date
    May 2010
    Location
    Livonia,Mi
    Posts
    671

    Re: YJ starting problem help!!!

    Recheck your conections at the battery,the starter relay(on the fender near the battery) & the starter...also check your ground wire to the frame. Hope that helps...let us know what you find.
    Tom Landvogt
    1978 CJ5(my toy)
    1999 TJ Wrangler Sahara(daily driver)
    2001 Cherokee Sport(wifes Jeep/winter driver)
    2002 Dodge Dakota(to tow the CJ & Wrangler)

  4. #4
    Branjmb's Avatar
    Branjmb is offline Member
    Join Date
    Aug 2010
    Posts
    66

    Re: YJ starting problem help!!!

    well i'm confused, but still diagnosing. I discovered of all things that my negative battery ground was not grounded-- just hanging there... but then i realized I HAD gotten the engine to start during that time it wasn't grounded.... So obviously I grounded it to the engine block.

    Now this starting problem happens intermittently. Fortunately only happened once today.

    What throws me off is I got it to run by jumping it by my friend's car, but i bought a new battery yesterday, so it's NOT the battery....
    Jeep Wrangler '92 YJ

Similar Threads

  1. Starting Problem
    By Cam98Chero in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 7
    Last Post: 01-04-2011, 05:11 PM
  2. starting problem
    By sweetpeet in forum CJ YJ TJ and JK
    Replies: 11
    Last Post: 08-25-2010, 06:38 AM
  3. Starting Problem
    By 74trs in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 3
    Last Post: 05-27-2010, 02:55 PM
  4. starting problem
    By bluehellsbells in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 2
    Last Post: 08-17-2009, 10:50 PM
  5. Starting Problem CJ7
    By goldot in forum CJ YJ TJ and JK
    Replies: 4
    Last Post: 10-10-2005, 04:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in