Page 1 of 2 12 Last

Thread: 4.0 Hesitation

  1. #1
    Jeeper99's Avatar
    Jeeper99 is offline Senior Member
    Join Date
    Jul 2008
    Location
    Tennessee
    Posts
    642

    4.0 Hesitation

    Anyone have a clue as to why my wrangler has a studder/hesitation when I first get in it and start to drive? I've heard a faint backfire through the throttle body. Once it clears out, it is fine the rest of the time I drive it. But if I park it for 10 minutes or longer, same thing happens when I first start to drive it??

    Any pointers would be great!
    l _____
    /l ,[____],
    l---L –()lllllll()-
    ()_)-()_)--o-)_)




    <img src=https://www.jeepz.com/forum/cacheJeepzImage.php?img=http%3A%2F%2Fi189.photobucket.com%2Falbums%2Fz154%2Fjonlipford%2FToys%2F011.jpg border=0 alt= />

  2. #2
    SteelHeadz's Avatar
    SteelHeadz is offline Moderator
    Join Date
    Oct 2008
    Location
    Kerrville, TX
    Posts
    6,087

    Re: 4.0 Hesitation

    Any diagnostic trouble codes? if not, try cleaning the t. body first and IAT.
    Confucious says: Don't eat the snow where the huskies go!

  3. #3
    JPNinPA's Avatar
    JPNinPA is offline Senior Member
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    4,661

    Re: 4.0 Hesitation

    Quote Originally Posted by SteelHeadz View Post
    Any diagnostic trouble codes? if not, try cleaning the t. body first and IAC.
    Fixed it for you.

    Could also be a O2 sensor going bad or an intake/vac leak.
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  4. #4
    Dace's Avatar
    Dace is offline Junior Member
    Join Date
    Nov 2007
    Posts
    28

    Re: 4.0 Hesitation

    Any raw fuel smell? Leaky injector(s) perhaps?

  5. #5
    blackhawkmike44's Avatar
    blackhawkmike44 is offline Junior Member
    Join Date
    Apr 2012
    Location
    Resaca, Georgia
    Posts
    4

    Re: 4.0 Hesitation

    i have a 99 sahara with exact same problem and im a tech at a gm store so i have some experiance but i have not been able to diagnois this but i did replace the tps and the crankshft pos sensor i also removed the throttle body and cleaned it nothing has improved when it sits for a few hours or overnite when you start driving it loses power no throttle responce bucking sounds like a lean backfire then suddenly it stops and wont do it again untill you shut it down for as little as hour or two at this point i dont know what to do next there is no check engine light and the tach never stopps working and it dont stall

  6. #6
    untamed's Avatar
    untamed is offline Senior Member
    Join Date
    Apr 2012
    Location
    Powell, WY
    Posts
    321
    Ok...just went through the exact same thing...i am picking my jeep up Wednesday from a great mechanic. Same symptoms as yours to the tee... This is what was explained to me...my fuel pump was only putting out 23psi and it should be in the 40s or more. Because of that the fuel injectors where getting crap built up in them and making them leak under pressure when you turn it off...if you let it sit long enough the gas will evaporate and it will start...i had him replace the fuel pump first then because it had more pressure the injectors leaked even more. So now he is replacing the injectors. It sucks and is expensive but maybe it will save you in paying for labor if you can do it yourself. Good luck

  7. #7
    untamed's Avatar
    untamed is offline Senior Member
    Join Date
    Apr 2012
    Location
    Powell, WY
    Posts
    321
    Check out thread got any ideas!!! I will update it when i pick the jeep up.

  8. #8
    Jeeper99's Avatar
    Jeeper99 is offline Senior Member
    Join Date
    Jul 2008
    Location
    Tennessee
    Posts
    642

    Re: 4.0 Hesitation

    Thanks for all the replies and pointers. I have taken the TB off and cleaned it, as well as TPS and all that. It has a newer distributor/rotor, plugs and wires. I also replaced both O2 Sensors a year or so ago. There is no raw fuel smell, no leaks that I can see. No codes or check engine lights have shown up.

    It has been doing this for a few months and I don't have the slightest clue as to what's going on. I have even started it up and let it run/idle for 10-15 minutes, then Drove off and the Hesitation starts. It lasts for about 5-6 seconds as it stutters, bucks and farts, then it is fine.......... Until I park it for 10 minutes or longer, then it starts all over again.
    l _____
    /l ,[____],
    l---L –()lllllll()-
    ()_)-()_)--o-)_)




    <img src=https://www.jeepz.com/forum/cacheJeepzImage.php?img=http%3A%2F%2Fi189.photobucket.com%2Falbums%2Fz154%2Fjonlipford%2FToys%2F011.jpg border=0 alt= />

  9. #9
    JPNinPA's Avatar
    JPNinPA is offline Senior Member
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    4,661

    Re: 4.0 Hesitation

    There is a known issue with rough idle and running post heat soak. There are faulty or missing heat shield on injector #3. You might want to look into this. Cheap fix if it' this.
    What brand O2 sensor? Some do not work well with these engines.
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  10. #10
    Catoctin Jeep's Avatar
    Catoctin Jeep is offline Official Vendor
    Join Date
    Aug 2009
    Location
    Bel Air, Md.
    Posts
    225

    Re: 4.0 Hesitation

    I may have missed a few things in this post, sorry if I did or sound redundant. Have you check the fuel pressure? The pump could be going up. When some motors start to go bad they don't get to there set rpm until they run for a little while, so maybe it's not picking up pressure from the beginning. You are saying that the engine is backfiring, this is telling me there is a lean mixture issue. Just throwing some thoughts out there.

  11. #11
    Jeeper99's Avatar
    Jeeper99 is offline Senior Member
    Join Date
    Jul 2008
    Location
    Tennessee
    Posts
    642

    Re: 4.0 Hesitation

    The O2 Sensors I got were factory replacments. What do you mean by faulty or missing heat shield on injector#3? Oh and it idles very smooth, always has.

    The engine backfiring through the manifold is once in a blue moon and it is very very faint. It hasn't done it in about a month.....

    I took the Manifold Temp sensor out and cleaned it with carb cleaner and blew it out with compressed air. Drove it too and from work today and it didn't seem to act up as bad??
    l _____
    /l ,[____],
    l---L –()lllllll()-
    ()_)-()_)--o-)_)




    <img src=https://www.jeepz.com/forum/cacheJeepzImage.php?img=http%3A%2F%2Fi189.photobucket.com%2Falbums%2Fz154%2Fjonlipford%2FToys%2F011.jpg border=0 alt= />

  12. #12
    JPNinPA's Avatar
    JPNinPA is offline Senior Member
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    4,661

    Re: 4.0 Hesitation

    On the injector for the third cylinder there should be a heat shield shaped like a hollow tube. If this is damaged or missing you will note an issue idling and running after starting the engine after a heat soak. The gas vaporizes in the injector causing a vapor lock. It will continue until the gas running through it cools it down enough to stop the vaporizing.
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  13. #13
    Jeeper99's Avatar
    Jeeper99 is offline Senior Member
    Join Date
    Jul 2008
    Location
    Tennessee
    Posts
    642

    Re: 4.0 Hesitation

    I went out and looked today and didn't see any kind of heat shield on the injector? I've never noticed one on it the whole time I've owned the Jeep. After cleaning the Manifold Temp sensor, I thought it helped, but thought wrong. It's still acting the same way when I start it up and begin to drive off.....
    l _____
    /l ,[____],
    l---L –()lllllll()-
    ()_)-()_)--o-)_)




    <img src=https://www.jeepz.com/forum/cacheJeepzImage.php?img=http%3A%2F%2Fi189.photobucket.com%2Falbums%2Fz154%2Fjonlipford%2FToys%2F011.jpg border=0 alt= />

  14. #14
    JPNinPA's Avatar
    JPNinPA is offline Senior Member
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    4,661

    Re: 4.0 Hesitation

    Does it do it when cold starts? Or only after running?

    http://www.jeepforum.com/forum/f9/cl...mmies-1114849/

    Also check for leaks around the TB, injectors and intake. Somtimes they are small enough leaks they close from the engine heating.

    Failing O2 sensor-you could unplug the sensor to see if the condition goes away. You will get a CEL and I don't recommend running like this, only for trouble shooting.


    THIS BULLETIN SUPERSEDES TECHNICAL SERVICE BULLETIN 18-027-02,


    DATED SEPTEMBER 06, 2002, WHICH SHOULD BE REMOVED FROM
    YOUR FILES. THIS IS A COMPLETE REVISION AND NO ASTERISKS
    HAVE BEEN USED TO HIGHLIGHT REVISIONS.
    SUBJECT:
    4.0L Rough Engine Idle After Restart Following A Hot Soak
    OVERVIEW:
    This bulletin involves the installation of a fuel injector insulator sleeve.
    MODELS:
    2000-2004 (TJ) Wrangler (Domestic and International Markets)
    1999-2004 (WJ) Grand Cherokee (Domestic and International Markets)
    2001-2004 (WG) Grand Cherokee (International Market)
    2000-2001 (XJ) Jeep Cherokee (Domestic and International Markets)
    NOTE: This bulletin applies to vehicles equipped with a 4.0L engine (sales code = ERH)
    SYMPTOM/CONDITION:
    Customers may describe a 20 to 30 second rough idle following the restart of a heat soaked
    engine. This condition may be most noticeable when the engine is restarted following a
    prior 10 to 20 minute heat soak in hot ambient conditions of approximately 32 C (90ºF)
    or higher. This condition may be consistent with short city stop-and-go driving trips and
    can be aggravated by the use of fuel with a high ethanol content. Depending upon
    various conditions a MIL may occur due to DTC P0303 - Cylinder #3 Misfire.
    This condition may be caused by heat from the exhaust manifold that following engine
    shut down migrates to the area around injector #3 and causes fuel vapor to form
    within the injector. This in turn may cause a momentary misfire of cylinder #3 until
    the fuel vapor is cleared of injector #3. The insulator sleeve lowers the injector #3
    temperature to a point below which the fuel will not normally vaporize.
    DIAGNOSIS:
    1. If vehicle exhibits a rough idle, and if a misfire of cylinder #3 is observed following
    a 10 to 20 minute hot soak, perform the Repair Procedure.
    18-031-03 -2-
    PARTS REQUIRED:
    Qty. Part No. Description
    1 56028371AA Ignition Wire Shield
    REPAIR PROCEDURE:
    1. Cut insulator sleeve, p/n 56028371AA, to make two (2) insulator sleeves
    about 25-30 mm (1 in.) in length.
    2. Install one sleeve around injector #3, with the slit on the upward facing side of the
    injector. Install the other sleeve with the slit on the downward facing side of the injector.
    3. Confirm sleeve is flush to intake manifold surface around injector.
    4. Check injector #3 wire and ensure that the injector is rotated to a 2 o’clock
    position (from driver’s side of vehicle


    http://www.jeepforum.com/forum/f9/cleaning-iac-throttle-body-write-up-dummies-1114849/
    Last edited by JPNinPA; 09-14-2012 at 07:06 AM.
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  15. #15
    Jeeper99's Avatar
    Jeeper99 is offline Senior Member
    Join Date
    Jul 2008
    Location
    Tennessee
    Posts
    642

    Re: 4.0 Hesitation

    Yea, i t does it on cold starts too. Pretty much anytime I first get in and initially drive off. It does it the same if the engine is warm or cold..
    l _____
    /l ,[____],
    l---L –()lllllll()-
    ()_)-()_)--o-)_)




    <img src=https://www.jeepz.com/forum/cacheJeepzImage.php?img=http%3A%2F%2Fi189.photobucket.com%2Falbums%2Fz154%2Fjonlipford%2FToys%2F011.jpg border=0 alt= />

  16. #16
    blackhawkmike44's Avatar
    blackhawkmike44 is offline Junior Member
    Join Date
    Apr 2012
    Location
    Resaca, Georgia
    Posts
    4

    Re: 4.0 Hesitation

    yea jeeper99 we have the exact same issue i have done all the repairs you have done but i did replace the pick up plate in the dist and thought that i may have found the problem but yesterday its was still running the same so im working on it if i find the problem i will post it maybe we will figure it out but its got me baffled and im a tech at achevy store and work on this kind of stuff everyday but cant fix my own jeep

  17. #17
    Jeeper99's Avatar
    Jeeper99 is offline Senior Member
    Join Date
    Jul 2008
    Location
    Tennessee
    Posts
    642

    Re: 4.0 Hesitation

    Anyone have any more suggestions?
    l _____
    /l ,[____],
    l---L –()lllllll()-
    ()_)-()_)--o-)_)




    <img src=https://www.jeepz.com/forum/cacheJeepzImage.php?img=http%3A%2F%2Fi189.photobucket.com%2Falbums%2Fz154%2Fjonlipford%2FToys%2F011.jpg border=0 alt= />

  18. #18
    untamed's Avatar
    untamed is offline Senior Member
    Join Date
    Apr 2012
    Location
    Powell, WY
    Posts
    321

    Re: 4.0 Hesitation

    It still sounds like low fuel pressure unless you have checked it and its good... which would make it run rich and backfire...I know what its like to go through this so I hope you find the problem soon...sucks when it doesn't run right.

  19. #19
    blackhawkmike44's Avatar
    blackhawkmike44 is offline Junior Member
    Join Date
    Apr 2012
    Location
    Resaca, Georgia
    Posts
    4

    Re: 4.0 Hesitation

    im still having this problem with my jeep just wondering if anyone has figured out the prblem yet i was hoping by now maybe JEEPER99 might have fixed his jeep i know we have the same problem!!!!! waiting on some good news maybe

  20. #20
    JPNinPA's Avatar
    JPNinPA is offline Senior Member
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    4,661

    Re: 4.0 Hesitation

    Quote Originally Posted by blackhawkmike44 View Post
    im still having this problem with my jeep just wondering if anyone has figured out the prblem yet i was hoping by now maybe JEEPER99 might have fixed his jeep i know we have the same problem!!!!! waiting on some good news maybe
    So what did you check from the suggestions and what did you find.
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

Page 1 of 2 12 Last

Similar Threads

  1. 258 hesitation at low rpm
    By epeterson in forum CJ YJ TJ and JK
    Replies: 4
    Last Post: 04-21-2009, 12:02 AM
  2. Hesitation... Help!
    By ezwrangler in forum CJ YJ TJ and JK
    Replies: 2
    Last Post: 07-09-2007, 10:42 AM
  3. Hesitation
    By Magua308 in forum CJ YJ TJ and JK
    Replies: 3
    Last Post: 06-15-2006, 11:02 PM
  4. hesitation when stepping on the gas
    By jaymed1998 in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 3
    Last Post: 07-20-2005, 08:13 PM
  5. hesitation
    By fattire23 in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 1
    Last Post: 07-20-2003, 07:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in