1. #1
    cj7chase's Avatar
    cj7chase is offline Junior Member
    Join Date
    May 2017
    Posts
    17

    1983 cj7 no power to fuel pump no spark

    Hi i am a relatively new owner of a 1983 CJ7 it has had a clean engine swap and currently have a 1992 4.2L in line 6. i recently noticed that the motor transfer case and transmission were all rotated (standing under car looking forward the left side was raised and right side was down). i took a look around and found that both motor mounts were sheared off. i put the jeep on a lift and used a jack stand to raise the motor and replace the motor mounts. It was a massive PITA and i had to raise the motor to the point where it was hitting the body. then had to figure out how to realign the motors before i was able to put the mounts back on. all said and done i completed it and took it off the lift excited to get it driving better than it has been for the last few months. Tried starting it and it "dry" cranked very solid. i have just replaced the starter and battery within the last 3 months and those are not the problem. i checked the fuel line and tried starting, no fuel. went to the pump, wasn't pumping. checked power to the pump and found that there was no power. i used a tool that adds power and added it to the pump. it shot out a steady stream of gas. so no problem with pump. traced the wire which was very difficult due to all the jerry rigging that has been done to it. then tried using starter fluid and again nothing. checked spark plugs and found that there is no spark. totally lost on what could be the issue as it ran perfectly normal before i replaced the motor mounts. and yes i have checked for any cut or disconnected wires or tubes and have found nothing besides the ones that are normally disconnected (once again due to the jerry rigging from the guy who owned it before). i have considered replacing the full wiring harness but am skeptical because i am not sure if that will fix the problem for sure. also i have not been able to check if i smashed or crushed or cut any wires or disconnects on the top of trans/transfer case (if there ever are any). and ideas greatly appreciated.

    thanks, chase

  2. #2
    Bill b's Avatar
    Bill b is offline Junior Member
    Join Date
    Mar 2017
    Posts
    16

    Re: 1983 cj7 no power to fuel pump no spark

    My first guess is a bad ground somewhere ????..or could be a bad relay..

    Sent from my XT1609 using Jeepz.com mobile app

  3. #3
    Bill b's Avatar
    Bill b is offline Junior Member
    Join Date
    Mar 2017
    Posts
    16

    Re: 1983 cj7 no power to fuel pump no spark

    Auto shut off relay. ??

    Sent from my XT1609 using Jeepz.com mobile app

  4. #4
    cj7chase's Avatar
    cj7chase is offline Junior Member
    Join Date
    May 2017
    Posts
    17

    Re: 1983 cj7 no power to fuel pump no spark

    thanks Bill, i will first go over all the grounds, disconnect them clean them and remount them as this is the free option. if the problem still persists i will check the auto shut off relay. just wondering, do you have an idea of where that may be located. i have already checked two relays that were mounted to the firewall and they did not solve anything.

    thanks, chase


    Sent from my iPhone using Jeepz.com mobile app

  5. #5
    Bill b's Avatar
    Bill b is offline Junior Member
    Join Date
    Mar 2017
    Posts
    16

    Re: 1983 cj7 no power to fuel pump no spark

    On my 1995 yj they are located under hood with the other relays and fuses. U can switch out the horn relay with auto shut down relay check if horn still work s, if not u have a bad auto shut down relay.good place to start. Good luck.

    Sent from my XT1609 using Jeepz.com mobile app

  6. #6
    cj7chase's Avatar
    cj7chase is offline Junior Member
    Join Date
    May 2017
    Posts
    17

    Re: 1983 cj7 no power to fuel pump no spark

    sorry it's been so long, haven't had much time to work on it lately. so i checked all grounds i could find, took them all of and filed them clean, solid metal on metal connections.. tried starting, still nothing. checked all the relays i could find and didn't find a problem with any of them. all fuses in fuse box are good. checked and tested. i decided to take a look at the ECU (computer) and started poking around... i have a tool that i can prod a wire and give that wire power if it needs it. i started stabbing wires that were in a wiring harness that was plugged into the ECU, found a wire that leads to the fuel pump because when i give it power the fuel pump kicks on. so based off my knowledge this should mean that from that wire to the fuel pump is all in working order correct? if this is true then i am led to believe that the issue is lying with my computer because it is the only other thing this side of the wire. i removed the computer and found out that my engine is actually out of a 92 XJ... EXCITING! the ECU says it's from a 91 but i figured that doesn't matter. as of now i am looking into getting a new ECU. willing to spend some money but i am not sure which one to buy as there are different part numbers that are only compatible with a specific engine. and i don't think i know enough about mine to make the right decision. here's what i know... 1992 XJ, in line 6, 4.0L, Manual trans, 5 speed... if any body has any knowledge on what i should buy or where to buy it from i'd love to hear. also anything else that you think could be causing my problem

    thanks, chase


    Sent from my iPhone using Jeepz.com mobile app

Similar Threads

  1. No power to fuel pump
    By glenn in forum CJ YJ TJ and JK
    Replies: 47
    Last Post: 06-27-2013, 01:12 PM
  2. No power to fuel pump or gauges
    By lunchbox07 in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 3
    Last Post: 06-25-2012, 11:19 PM
  3. power to the yj fuel pump question
    By tailights24 in forum CJ YJ TJ and JK
    Replies: 2
    Last Post: 02-16-2011, 07:47 AM
  4. Replaced Fuel pump, now no spark?
    By tannerp89 in forum CJ YJ TJ and JK
    Replies: 6
    Last Post: 07-21-2010, 10:42 AM
  5. help, no power to fuel pump/injectors
    By mcgbail in forum CJ YJ TJ and JK
    Replies: 8
    Last Post: 02-10-2009, 08:47 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in