1. #1
    jeepanu's Avatar
    jeepanu is offline Junior Member
    Join Date
    Sep 2019
    Location
    Dual living... Montreal Canada; Puerto Plata Dominican Rep.
    Posts
    3

    Instrument cluster

    I have a Jeep Wrangler 2002 SE 2.5l 5M. The cluster is blocked at 888888.
    Daily is working...
    I remove the cluster, clean it with electric cleaner, I put dielectric grease on connectors,
    but still nothing...
    So, somebody can help me?
    Thanks

  2. #2
    JPNinPA's Avatar
    JPNinPA is offline Senior Member
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    4,773

    Re: Instrument cluster

    Check fuses. Specifically #4 behind glovebox.
    Run cluster diagnosis test. Reset pushed key to on let reset out.
    Check all pins are making contact in cluster.


    Regards,
    JPNinPA

    Sent using TapTalk
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  3. #3
    jeepanu's Avatar
    jeepanu is offline Junior Member
    Join Date
    Sep 2019
    Location
    Dual living... Montreal Canada; Puerto Plata Dominican Rep.
    Posts
    3

    Re: Instrument cluster

    Thanks for the answer. The test is done more than one time. No changes. The only thing to do is to check the fuse, but I suppose that is good because is used also for something else... about the pins...I will try. When I strip the cluster I look at the pins and I didn't see
    any corrosion or bad connexion... Anyway... in vacation... with some beer aside I will check again.

  4. #4
    JPNinPA's Avatar
    JPNinPA is offline Senior Member
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    4,773

    Instrument cluster

    Usually pins are compressed metal and spring like. After some time and weight....the spring relaxes then bends until no connection. So the blade end may look fine but the opposite is the issue. I don't know how much space is there and if you could do this and monitor at the same time. But you should be able to wiggle or push the each wire connection from the backside to determine if it is one pin.


    Pic from a broken connector
    Instrument cluster-img_2914.jpg

    Regards,
    JPNinPA

    Sent using TapTalk
    Last edited by JPNinPA; 09-12-2019 at 11:14 PM.
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  5. #5
    JPNinPA's Avatar
    JPNinPA is offline Senior Member
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    4,773

    Re: Instrument cluster

    Found this if ever needed



    Regards,
    JPNinPA

    Sent using TapTalk
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  6. #6
    jeepanu's Avatar
    jeepanu is offline Junior Member
    Join Date
    Sep 2019
    Location
    Dual living... Montreal Canada; Puerto Plata Dominican Rep.
    Posts
    3

    Re: Instrument cluster

    OK,Thanks I will try that also... in December when I go in vacation... This Jeep is in Dom.Rep. ... the mileage is not very important
    there but I don't like when something don't work properly...

Similar Threads

  1. Instrument Cluster 01
    By 01jeepgc in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 1
    Last Post: 03-12-2015, 02:23 PM
  2. instrument cluster not functioning
    By bert37 in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 1
    Last Post: 01-16-2013, 08:11 AM
  3. TJ instrument cluster beeping
    By Crazy4diesels in forum CJ YJ TJ and JK
    Replies: 6
    Last Post: 11-23-2010, 10:41 AM
  4. instrument cluster
    By tjc in forum CJ YJ TJ and JK
    Replies: 2
    Last Post: 07-22-2009, 09:16 PM
  5. If anybody needs an instrument cluster...
    By IRPancake in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 6
    Last Post: 08-23-2008, 07:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in