1. #1
    smalls42010's Avatar
    smalls42010 is offline Junior Member
    Join Date
    Nov 2019
    Posts
    6

    05 Jeep loses power in 3rd

    Ok so i just started having this problem this morning.
    When ever I shift into 3rd or 4th gear I lose all power to my jeep it only does it after ive been driving for about 15 20 mins.
    its a 05 wrangler 4.0 6speed stick.
    all ideas would be appreciated, Thanks

  2. #2
    JPNinPA's Avatar
    JPNinPA is offline Senior Member
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    4,953

    Re: 05 Jeep loses power in 3rd

    Is the CEL check engine light on? What codes show?

    When this is occurring does the rpm go up but you donít go faster?
    Slipping clutch??
    Check clutch fluid. Possible failing slave cylinder.
    Worn out clutch.

    After a few min the engine warms and goes into closed loop. This is when it uses info from O2, temp, map and cpk and cps sensors.

    Is your idle fast or slow? What rom do you idle at?




    Sent from my iPhone using Jeepz.com mobile app
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  3. #3
    smalls42010's Avatar
    smalls42010 is offline Junior Member
    Join Date
    Nov 2019
    Posts
    6

    Re: 05 Jeep loses power in 3rd

    no check engine light is on.
    slave cylinder is fine
    when it does it its just dies but after a second or 2 it comes back to life
    but it doesn't do it all the time that's what gets me.
    idles fine

  4. #4
    JPNinPA's Avatar
    JPNinPA is offline Senior Member
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    4,953

    Re: 05 Jeep loses power in 3rd

    Certain pedal position? TPS may have dead spots.


    Sent from my iPhone using Jeepz.com mobile app
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  5. #5
    smalls42010's Avatar
    smalls42010 is offline Junior Member
    Join Date
    Nov 2019
    Posts
    6

    Re: 05 Jeep loses power in 3rd

    Quote Originally Posted by JPNinPA View Post
    Certain pedal position? TPS may have dead spots.


    Sent from my iPhone using Jeepz.com mobile app
    Maybe, ill check into that. it has a brand new tps on it

  6. #6
    JPNinPA's Avatar
    JPNinPA is offline Senior Member
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    4,953

    Re: 05 Jeep loses power in 3rd

    Have you pulled and inspected your plugs?
    They can show signs of oil burning, lean or rich conditions...


    Sent from my iPhone using Jeepz.com mobile app
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  7. #7
    smalls42010's Avatar
    smalls42010 is offline Junior Member
    Join Date
    Nov 2019
    Posts
    6

    Re: 05 Jeep loses power in 3rd

    Quote Originally Posted by JPNinPA View Post
    Have you pulled and inspected your plugs?
    They can show signs of oil burning, lean or rich conditions...


    Sent from my iPhone using Jeepz.com mobile app

    No i have not, ill check into it in the am

  8. #8
    JPNinPA's Avatar
    JPNinPA is offline Senior Member
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    4,953

    Re: 05 Jeep loses power in 3rd

    Post pics of each plug


    Regards,
    JPNinPA

    Sent using TapTalk
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  9. #9
    smalls42010's Avatar
    smalls42010 is offline Junior Member
    Join Date
    Nov 2019
    Posts
    6

    Re: 05 Jeep loses power in 3rd

    Quote Originally Posted by JPNinPA View Post
    Post pics of each plug


    Regards,
    JPNinPA

    Sent using TapTalk

    Sorry for the late response, all plugs were fine.

  10. #10
    JPNinPA's Avatar
    JPNinPA is offline Senior Member
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    4,953

    Re: 05 Jeep loses power in 3rd

    Figure it out?



    Regards,
    JPNinPA

    Sent using TapTalk
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  11. #11
    smalls42010's Avatar
    smalls42010 is offline Junior Member
    Join Date
    Nov 2019
    Posts
    6

    Re: 05 Jeep loses power in 3rd

    Quote Originally Posted by JPNinPA View Post
    Figure it out?



    Regards,
    JPNinPA

    Sent using TapTalk
    Yes I did, it was my crank position sensor.
    Thanks for your help!

Similar Threads

  1. Jeep yj loses power while driving
    By CplRecon in forum CJ YJ TJ and JK
    Replies: 25
    Last Post: 11-25-2017, 12:36 PM
  2. Ticks at high RPM's loses power when ticking starts, what could be the problem? VIDEO
    By Dragon-Kin in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 2
    Last Post: 04-08-2014, 02:56 PM
  3. Cj-5 loses all power when i turn the key
    By bexican73 in forum CJ YJ TJ and JK
    Replies: 5
    Last Post: 02-25-2012, 10:52 AM
  4. 85 Grand Wagoneer loses power while driving
    By Florence725 in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 9
    Last Post: 08-10-2011, 09:55 AM
  5. 1998 Cherokee 2.5 td loses power/acceleration
    By pants in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 2
    Last Post: 05-19-2005, 09:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in