1. #1
    soaringeagle's Avatar
    soaringeagle is offline Junior Member
    Join Date
    Dec 2019
    Posts
    1

    jeep dosent ide right

    97 jeep 1997 2.5 wrangler
    when i start jeep when its a cold engine it sputters idle s so rough it has died i have to restart i have replaced so many things thinking it would be the problem but it still does it does anyone know maybe if i have a bad coil causing problem or ecm if i let it warm up to 200 degrees everything seems ok but first time starts terrible im at a lost

  2. #2
    JPNinPA's Avatar
    JPNinPA is offline Senior Member
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    5,026

    jeep dosent ide right

    Check that your temp sender is reading correctly. There may be two one for the gage and one for the PCM. Check the one for the PCM. Other than this a slow upstream O2 can do this.

    Any CEL


    Regards,
    JPNinPA

    Sent using TapTalk
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

Similar Threads

  1. Newbie dosent no
    By Buck hour in forum New Member Introductions
    Replies: 1
    Last Post: 11-29-2010, 05:35 PM
  2. Left Turn signal dosent work, but flasher works fine
    By cundifc in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 2
    Last Post: 12-30-2009, 07:55 PM
  3. Driver door dosent close well
    By 93bizzleYJ in forum CJ YJ TJ and JK
    Replies: 2
    Last Post: 09-10-2003, 07:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in