Thread: jeep problem

  1. jeep problem

    I have a 1998 jeep grad cherokee laredo with the 4.0 ... every once in awhile my motor will spit and sputter like bad fuel or vacume leak i have to put in nutural and rev it up and put it back in gear mostly happens when leaving a stop it will back fier threw throttle body ran smoke test threw vacume and
    I put in new fuel pump. New cap rotor distributor plugs and wiers. No check engine light ...any advice ???

  2. #2
    Join Date
    Apr 2013
    Location
    Staten Island n.y.
    Posts
    2,000

    Re: jeep problem

    Welcome to Jeepz.com Travis . You might want to be sure none of those plugs got cracked on install , just to be sure you don't have a miss because of that. Check the cap and rotor for pitting since you got back firing too. If all that checks out , may be working on a ignition coil going bad .
    Check spark quality on all cylinders . Hope you changed the fuel filter and your fuel pressure is strong. Let's start there before we get into things like O2 , map and TPS sensors . Let us know what you find . Sometimes it takes a long check list and sometimes you find the cause right away. Never overlook the obvious and don't assume just because you already changed something , I.E. , spark plugs that they're alright . You got a problem and we can't leave no stone unturned .

  3. Re: jeep problem

    Ive checked plugs cap there fine already changed fuel pump and filter put in new map senser

  4. #4
    Join Date
    Apr 2013
    Location
    Staten Island n.y.
    Posts
    2,000

    Re: jeep problem

    Well , I'm happy you've got some new parts on , hoping your fuel pressure is fine as we would expect with a new fuel pump . Hoping as well that the quality of spark on all cylinders is strong.
    You posted that a smoke test was done to find any vacuum leaks , I guess you did not or you would have mentioned there were leaks . Now we have to check what is causing intermittant idle quality to suffer. No check engine light and no trouble codes stored . We always say to start with the simple things so you can clean the throttle body and idle air valve motor to rule that out .
    Since you did not report any starting problems the idle control motor is probably alright .
    The usual cleaning of electrical connections such as battery terminals so that there is no voltage drop to your electrical system that will affect the PCM and cause such driveability problems .
    clean all grounds as well so that , again , the PCM and other engine sensors can work properly .
    One item that tends to get overlooked and causes a rich condition is the emmissions evaporative canister purge valve . If faulty , will cause rough idle and possible stalling upon acceleration due to over rich condition . This is something worth checking since your jeep is experiencing just that , poor take off , however slight or frequent . You can try to disconnect temporarily by plugging the feed to the intake to see what effect it has on the problem . This seems like it will be a process of elimination . Generally , after checking each item and eliminating one by one , it's hopeful that the cause is found soonest but should be found eventually which I know is what you are asking for , food for thought. As I previously posted , a long list of items could be checked until all possible causes are illuminated as checks and procedure are exhausted.

  5. Re: jeep problem

    All electeral connections to battery r cleaned and tight when my problem accurs my volts do drop .. I was thanking the computer was going bad?? And i will check the purge valve
    In the am . And thanks for all ur advice

  6. #6
    Join Date
    Apr 2013
    Location
    Staten Island n.y.
    Posts
    2,000

    Re: jeep problem

    There is a possibility the voltage regulator , which is built in on the PCM could be at fault . We must remember that a healthy battery and charging system is necessary for a PCM to work properly and for all sensors to function properly as well . Our best diagnostics tool at this point will be a scan tool . If possible , a hand held one with flight can be used on a test drive to try to trigger the glitch and capture its reading to find the power loss . If this is not possible , a dyno session will have to be done which unfortunately means a diagnostic fee . Let's try to exhaust all checks up to that point before spending that fee . When an engine either stales or misses and rpms drop , naturally , the alternator reduces speed and there is a voltage decrease ( drop ) which is sensed by the PCM . If there is just a driveability problem such as a over rich condition that is causing the engine to stumble , this must be corrected as being the obvious to see if this corrects the problem or at least eliminates one more problem. Let's not jump to the extreme , this may still be within your scope to diagnose before going to the shop . Autozone does read codes for you but I do not know if they will scan for driveability problems . If you feel your PCM may be at fault , start inspecting engine harness wiring that feeds back to the PCM for any shorts that may have caused a fault in the PCM . A PCM does not just wear out , they short due to an electrical problem caused by wiring shorts or a surge that draws more voltage than the circuit normally puts out or reads . We must do,all we can inspection wise and check the simplest things we can that we are capable of before a dyno session is applied . It's terrible to find out you paid a high price for this service and the result was for example a faulty intermittant purge valve on the evap tank . I personally try to avoid that . I hate paying money to someone when I could have found and fixed myself. Realizing your asking for what to diagnose so that you can in fact do it yourself is what we can help with . Ok , to recap , if your satisfied with fuel pressure and spark quality is strong , we must comtinue to go after the computer related items . Simply , if a sensor misses a beat but does not log atroubke code because it does not do this long enough or enough times to be significant , the code never logs . Conversely , if there is a fault in the PCM and it is not reading sensors correctly , this happens too . It will come down to inspection of wiring , vacuum lines and everything visual since there is no trouble code to help us . Yes , a scan tool will speed up things by reading sensor input and output , alternator and other functions but if not available , manual checks will have to be employed . I went through this in December 2004 with my '92 XJ and went as far a my multimeter can go before the display froze in single digits temperatures . I was nearly sure it was the PCM not putting out strong enough voltage to the coil . Turns out I was right , but a Chrysler dealer had to charge me to find it ( indoors of course ) and replace the PCM . If I could have just gotten it started , I could have read coil volts cranking and running . Hope you are not experiencing a problem this extreme .

  7. Re: jeep problem

    I went threw all wireing today everything seems to b fine. I was able to finde a spare computer today to swop with mine and still have problem. i do kno my battery is not quite putting out the amps it needs to ..
    I am completly stumped....

  8. #8
    Join Date
    Apr 2013
    Location
    Staten Island n.y.
    Posts
    2,000

    Re: jeep problem

    I've a question , the intermittant miss and stumble your experiencing , does it only happen when you accelerate or will it happen when at idle with your foot off the accelerator ? Your MAP sensor has been replaced , fuel pump too , that leaves the knock sensor and TPS . I haven't seen knock sensors to cause this , but a TPS can. Before replacing , check for smooth voltage increase key on engine off with a voltmeter by back probing the signal and reference wires . If there is a miss on the meter , replace the TPS. I'm not yet ready to blame a faulty injector , but we will keep that in mind . My brother replaced injectors on two jeeps , a 4.0 liter '98 grand and 4.7 which displayed similar driveability problems. Injectors are $$ , I would only tell you to replace if we are certain.
    Right niw , your jeep is starting and idling good until it randomly and intermittently acts up.
    I don't think you have an injector issue , so testing would be a little harder . Normally , if the engine idling poor , you would disable a cylinder by grounding a spark plug cable to see if the idle is affected . Since your engine runs well most of the time , doing this will only cause a miss in every cylinder you ground , proving nothing . You would literally have to catch the right injector at the time of the fault . Sensor checks will need to be done to once again , process of elimination , rule out good or bad . TPS , coolant temp (CTS) , oxygen sensor(o2) , cam and crank sensors as well will need to be checked if in or out of spec .
    Never overlook the obvious . It's usually right in front of us

  9. Re: jeep problem

    It will stumble mostly on take off but it has stumbled at first start to

  10. #10
    Join Date
    Apr 2013
    Location
    Staten Island n.y.
    Posts
    2,000

    Re: jeep problem

    There may be a sensor out of spec . At start up the PCM relies on feedback from the coolant temp sensor , O2 sensor cam and crank sensors mainly but before replacement , all sensors will have to be checked . Since the engine has its good moments , the O2 sensor may still be ok but cam and crany sensors keep the engine running by feeding back position to keep the proper firing order for the fuel injectors and proper spark advance which the PCM supplies voltage directly to the ignition coil. If the CTS is within range , the PCM knows enough to go from open to closed loop for normal operation and hopefully the knock sensor is within range as well to read correctly and not cause a glitch I know it strange to you that your having driveability problems and no troubles logged even after swapping a PCM but this PITA intermittant problem is messing with the normal function of the PCM . This seems like is being caused by out if specification sensor(s) not properly feeding back critical information the PCM needs to continue to run the engine normally.
    To recap ; you've changed the fuel pump and hope your getting adequate fuel pressure , a MAP sensor and we hope that feeds back right ( parts quality ?) etc. etc. , but do we know what state the fuel pressure regulator is in ? Also , and this is important to the PCM , is the alternator putting out properly ? You posted you believe the battery is not putting out enough AMPS , this can be significant . For a PCM to work right , it needs its voltage or it can't power sensors and run injectors and so on if it can't supply the voltage which is generated from the alternator.
    Its doubtful that two PCM's have faulty voltage regulators but one never knows and would have to be verified . By now this has gotten you upset to the point where you can lose all reasoning and get lost and stumped but if you tackle one Tim at a time , keep notes as you probably are ,
    process of ILLimenation does work and does prevail. There's only so many parts under the hood so you know you will get to them all . I have not forgotten that your quest for help is to help guide you in the right direction so the cure is found and less time lost on research and more on fixing and driving reliably . To the best if your ability , I believe you can cover all these checks and find the bug. It starts and runs so I feel all is needed is to find the what's trying to break the communication between PCM and what it powers to run the engine . It could be an out of spec sensor or even a short at a harness plug on a sensor we can't clearly see . On some engines coolant temp,sensors are good for this but of any work has been done next to any electrical , these things can happen and do . It just forces us to link harder . In addition to simple tests we are looking for we must still be sure all connections are solid or we buys parts and it still dosen't fix. Trying to avoid this for you . I , to this day , still insist on proper diagnostics as has been drilled into me by several people in the past whom I've always trusted . One was a parts store owner if you can believe that . Please don't give up as I have seen posts by members too many times that it tested them royally but laughed when they found and fixed it . It's always something dum that causes this , even if it's just a worn part . Please hang in there , I'm sure this jeep is well worth the trouble .
    Last edited by greg92jeepxj; 02-02-2014 at 10:41 PM.
    Never overlook the obvious . It's usually right in front of us

  11. Re: jeep problem

    Scary huh.
    Needs to go yonder.

  12. #12
    Join Date
    Apr 2013
    Location
    Staten Island n.y.
    Posts
    2,000

    Re: jeep problem

    Quote Originally Posted by Gennybro View Post
    Scary huh.
    Yeah , but he'll get this beat . Hope he's got his money down on Seattle , we'll get him back in the game.
    Never overlook the obvious . It's usually right in front of us

Similar Threads

  1. jeep problems galore
    By MudderChuck in forum Wrangler and CJ
    Replies: 9
    Last Post: 07-20-2003, 08:00 PM
  2. Non-Jeep Problem
    By Quik8slvr in forum Wrangler and CJ
    Replies: 16
    Last Post: 07-20-2003, 08:00 PM
  3. My first Jeep problem
    By MudderChuck in forum General Chat
    Replies: 9
    Last Post: 07-20-2003, 08:00 PM
  4. Jeep Problems and Questions
    By dingus in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 5
    Last Post: 07-20-2003, 08:00 PM
  5. ok jeep problem again.
    By joeycj5 in forum Wrangler and CJ
    Replies: 9
    Last Post: 07-20-2003, 08:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in