Page 17 of 17 First ... 7151617
  1. #321
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    5,944
    Quote Originally Posted by quicksand97 View Post

    O no you mean It could be a 02, Ah man, well I am not throwing any codes but I did have the exhaust manifold replaced about 2 months ago, and with the old one I had it all getto with exhaust sealer,puddy and bubble gum. Could it be the 02 has residue on it ? Do I just replace it or can it be cleaned?
    When my O2 sensor internal heater failed no code was thrown. But I did note my short city trips mpg was terrible.

    Being you had e exhaust off you had the intake off as well. Small leaks may seal once the engine comes up to temp. If your rough takeoff is only when the engine is cold but not on warm starts it is either the O2 or a intake leak. At a min borrow a scan gauge and watch the O2 signals. You could also spray around the intake with carb/injector cleaner when ideling and listed for a change in rpm.
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  2. #322

    Re: 2.5L performance?

    Quote Originally Posted by JPNinPA View Post
    When my O2 sensor internal heater failed no code was thrown. But I did note my short city trips mpg was terrible.

    Being you had e exhaust off you had the intake off as well. Small leaks may seal once the engine comes up to temp. If your rough takeoff is only when the engine is cold but not on warm starts it is either the O2 or a intake leak. At a min borrow a scan gauge and watch the O2 signals. You could also spray around the intake with carb/injector cleaner when ideling and listed for a change in rpm.
    Yep sounds good, I gotta do that then, that little bucking just really bugs me. Thanks for that info, I will check for intake leaks soon as I get some time, Thank you Sir.

  3. #323
    Join Date
    Feb 2012
    Location
    Bridgeview, Illinois, United States
    Posts
    120

    Re: 2.5L performance?

    I had a hard bucking problem turned out to be my crank sensor failed. Causing hell on my motor.
    Honesty is my policy

  4. #324
    Join Date
    Oct 2013
    Location
    Mass soon to be in NH
    Posts
    12

    Re: 2.5L performance?

    I have a bucking problem in 4th gear around 40 MPH on acceleration up a slight incline. It doesn't happen all the time so this diagnostic was a ***** to figure out. The mechanic thinks it's my distributor more than the TPS or the Crank Sensor. So the repairs go on and on and on.
    Just Entertain Every Possibility. Drive it till it breaks then fix it to start all over again. It never gets old!!!

  5. #325

    Re: 2.5L performance?

    Quote Originally Posted by White Buffalo View Post
    I have a bucking problem in 4th gear around 40 MPH on acceleration up a slight incline. It doesn't happen all the time so this diagnostic was a ***** to figure out. The mechanic thinks it's my distributor more than the TPS or the Crank Sensor. So the repairs go on and on and on.
    Yea just recently, last month I had my exhaust manifold replaced for the second time in 7 years, and had to remove it again a week later to replace the freeze plugs that where corroded and leaking antifreeze behind the exhaust manifold. Along with that replaced a bad leaky power steeriing pressure sensor. Was wondering for a long time why I had little bit of oil built up on driver side of engine and always wiping components and sensors and connectors. Finally use some throttle body cleaner to help clean oil on that side side. Got to do it a few more times. Will she has been running alot better lately since there is no exhaust leak, and with the steering sensor replacement the RPM is staying equalized. What that sensor does is send a signal to PCM telling it to raise RPMs a bit when you turn your steering wheel so your RPMs do not drop, sinse it takes more power to turn. Main sensors for everything Huh. O well enough said for now. You all talk care and Happy 4 Wheeling.

  6. #326

    Re: 2.5L performance?

    O yes my bucking is way down with the first start of the day now, I do feel just a wee bit then goes away. I will look into swapping CPS sensor ?

  7. #327

    Re: 2.5L performance?

    Quote Originally Posted by White Buffalo View Post
    I have a bucking problem in 4th gear around 40 MPH on acceleration up a slight incline. It doesn't happen all the time so this diagnostic was a ***** to figure out. The mechanic thinks it's my distributor more than the TPS or the Crank Sensor. So the repairs go on and on and on.
    Huh thats wierd up hill, huh I had a similar problem years back, but mine would buck on left turns only. It turned out to be the fuel pump. Its located inside the gas tank on my 97. Huh of all places. Dont remember what it cost me, it was years ago. To me I not any expert other than what I have been thru myself. In my opinion does not sound like distributor. A bad distributor you would have miss fire, irractic idle or timing problems. Maybe even starting problems. Man always something with these jeeps. Love my lil 4 banger and through the years have came to know every bolt on it. Well we wish you the best, keep us posted.

  8. #328

    Re: 2.5L performance?

    Hey there guys I'm have some problems with my 2.5 in my 95 YJ . Had the bottom end rebuilt and before the rebuild it ran fine had good power and now that it's been rebuilt the powers not there I can only get up to 35mph. If anyone has any ideas please let me know.

  9. #329

    Re: 2.5L performance?

    Quote Originally Posted by HawaiianOhioJeeper44 View Post
    Hey there guys I'm have some problems with my 2.5 in my 95 YJ . Had the bottom end rebuilt and before the rebuild it ran fine had good power and now that it's been rebuilt the powers not there I can only get up to 35mph. If anyone has any ideas please let me know.
    Had same problem a few months after I rebuilt my 2.5. It was a clogged cat converter. Replaced with brand new cat, ran great after that.
    "My Jeep won the war; your Honda can mow my lawn!"

  10. #330

    Re: 2.5L performance?

    Quote Originally Posted by MoparMatt77 View Post
    Had same problem a few months after I rebuilt my 2.5. It was a clogged cat converter. Replaced with brand new cat, ran great after that.
    Man thats wierd on that only getting up to 35 MPH, I hate to hear stuff like that, you go have something fixed to make it better and you end up with something worse. Man that grinds my gears. I wish you the best on finding out what the heck is going on with that rig.

  11. #331

    Re: 2.5L performance?

    Yeah I was really lost when it had everything fixed and then ran like a dead dog. And I really like my 2.5 to me I think it's a great motor. But I'm gonna try the change of the cat and see what happened. Thanks

  12. #332
    Join Date
    Oct 2013
    Location
    Mass soon to be in NH
    Posts
    12

    Re: 2.5L performance?

    I finally got my TJ to throw a code today, P0204. It says it is a problem with the number 4 injector. The cure is change the injector, check the wiring for a signal or change the PCM. I was going to change the injectors to the Ford 24 pound injectors anyway so I'll do that first and check the signal from the injector wire at the same time as this will let me know if the PCM is on its way to the scrap pile. Will let you all know what I find out as soon as I get the injectors and install them. Maybe this will cure my hesitation up a small incline when stating out while shifting from 3rd to 4th gear.
    Just Entertain Every Possibility. Drive it till it breaks then fix it to start all over again. It never gets old!!!

  13. #333

    Re: 2.5L performance?

    Quote Originally Posted by White Buffalo View Post
    I finally got my TJ to throw a code today, P0204. It says it is a problem with the number 4 injector. The cure is change the injector, check the wiring for a signal or change the PCM. I was going to change the injectors to the Ford 24 pound injectors anyway so I'll do that first and check the signal from the injector wire at the same time as this will let me know if the PCM is on its way to the scrap pile. Will let you all know what I find out as soon as I get the injectors and install them. Maybe this will cure my hesitation up a small incline when stating out while shifting from 3rd to 4th gear.
    Sounds like it makes since, I pray it works out for you. Keep us posted on how it turns out and the results on the 24 pound injectors, Take Care.

  14. #334
    Join Date
    Oct 2013
    Location
    Mass soon to be in NH
    Posts
    12

    Re: 2.5L performance?

    I ordered the injectors tonight but I put an injector cleaner in the gas tank and it ran just fine with no bucking going up a slight hil in 4th gear. That seemed to pinpoint the problem as being the no 4 injector being bad or plugged. I should have the injectors next week and installed shortly after that. Maybe this will be the cure but if it isn't then I'll have the wires checked and if they are OK I'll do the PCM. My Jeep runs fine and fast except up hill as is with all 4 bangers. It has great throttle response but lacks the power. I just want a little bit more power as I'm use to my Tundra's V8 but I still love to drive the TJ. Will keep everyone informed.
    Just Entertain Every Possibility. Drive it till it breaks then fix it to start all over again. It never gets old!!!

  15. #335

    Re: 2.5L performance?

    Quote Originally Posted by White Buffalo View Post
    I ordered the injectors tonight but I put an injector cleaner in the gas tank and it ran just fine with no bucking going up a slight hil in 4th gear. That seemed to pinpoint the problem as being the no 4 injector being bad or plugged. I should have the injectors next week and installed shortly after that. Maybe this will be the cure but if it isn't then I'll have the wires checked and if they are OK I'll do the PCM. My Jeep runs fine and fast except up hill as is with all 4 bangers. It has great throttle response but lacks the power. I just want a little bit more power as I'm use to my Tundra's V8 but I still love to drive the TJ. Will keep everyone informed.
    Well I wish you the best. Yeah I took several years to get my Lil Monster 4 Banger finally feel real good to drive on and off road. It seems like I have been on a budget for a long time now and everything on my rig is budget built. Its got a red top optima battery to start things up followed by a CRT performance coil that is rated at 45,000 volts, 8mm Accel wires with NGK plugs gapped at a mere .039. Also homemade cold air intake using K&N flat panel filter with modified factory air box with ram air along with a adjustable side aluminum air plate to fine tune the amount and air and air force entering a larger air tube. Air tube is insulated to keep air temps down for whats its worth. A 4.0L Throttle body with half shaft and top side bored with a 62mm seam. Bottom side of throttle body kept at stock 55mm in order to keep V shape intake, which I believe keeps a strong air charge without losing any torque. Ofcouse bored out intake manifold to 55mm to macth TB. Used a custom throttle body power spacer made of teflon and has velocity air blades inside. Not to swirl air but to increase air charge. Has a nozel air presure affect. Keep the factory exhaust manifold for now. Followed by a catback straight flow system. I am a mild wheeler and like to keep my wieght down. I did remove back seat and have a decent setup back there with a nice sound system and all the tools I need in tool box, air compressor on so on. Still running on a budget boost with 31s with 4.10 and some quick disconnects. I do have a Rad Shak CB with 4ft firstik and coil spring. Been messing with that lately trying to tune it up with no meter. Outer trim includes front headlight gaurds, rear light gaurds, kilby steering skid plate, red front tow hooks, homemade solar nets, kinda like cargo nets. O yea I also trimmed down and cut my factory radiator fan lil by little and seems to really spool up alot faster, with faster take offs and inproved cooling. Anyway every little thing works in sync with the other. Not one mod is gonna make a world of difference by itself. O yes the cockpit does look like a aircraft with so many swicthes and close attention to detail. I have amber fog light, clear fog lights at bottom of wieldshied mounted in like a 45 degree angle outward, wired on seperate left and right swicthes. Just below side view mirrors are a pair of flood lights also mounted on 2 seperate left and right swicthes. Ofcousre a swicth for backup flood lights. 2 flood ground lights 1 downward by front axle and one downward on back axle. Yes on two seperate swicthes. Yada yada yada. Enough said for now, caught me in a talktive mood. You all take care and Happy Wheeling. Hmm wondering if I should hard mount my power inverter on passenger kick panel ? Hmm maybe another swicth. Who knows, Fun.

Page 17 of 17 First ... 7151617

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in