1. #1
    kmitch80's Avatar
    kmitch80 is offline Junior Member
    Join Date
    Jul 2009
    Location
    alamogordo, new mexico
    Posts
    4

    95 jeep GC 4.0 stuck in "LIMP MODE"

    ok, so to add to my overheating issue, really not that big of an issue, my transmission just decided to start bein retarded. Sun afternoon i put in a new transfer case, bolted right up, plugged it in, did a little rock crawling. Tues i decided to change out the transmission fluid and filter only cuz it hasnt been done in about, 70,000 miles or so. (yeah i know) so dropped the pan, drained it into a bucket, well some of it, changed the filter and put it back together. Forgot the ATF at the store so picked sum up from a convenience store down the street, BIG MISTAKE. Put the ATF in, warmed it up, ran it around the block, added a bit more and went rock crawling again to check things out. All seemed ok. Wed everything is fine. thursday morning wake up, start it up, leave the house and only get first gear, nothing else no matter wut i do. switched the ignition off and on while driving a few times to see if it helped. After 10 times or so, it stopped doing what it was doing and drove fine rest of the day. Did it again this morning, (friday) so look at my atf and says "not suitable for cars made after 1963." WTF!!??Who the hell stocks this stuff!?!? so go to the store, buy the good stuff, drop the pan change it again, no help. Stuck in 1st gear entire day, do sum reading see that people have problems with governor pressure sensor and solenoid. replaced them both and now, only have 2nd and 3rd and thas manually shifting. And even first if shifting from neutral to 1st. Took it to have codes checked, no codes came up, so nothing to clear off the computer, tried disconnecting battery for an hour or so and still nothin. O/D light stays on and stuck in LIMP mode. So after my long story and even longer week, this is how it ends up. Any ideas out there what to do next???? Cuz im stuck anf frustrated as hell!!

  2. #2
    SteelHeadz's Avatar
    SteelHeadz is offline Moderator
    Join Date
    Oct 2008
    Location
    Kerrville, TX
    Posts
    6,087

    Re: 95 jeep GC 4.0 stuck in "LIMP MODE"

    Try performing a flush and use an ATF+3 or ATF+4 mopar or compatible fluid..It's kinda odd that it got stuck on first..The limp in mode on your Jeep make and model is second gear..
    Confucious says: Don't eat the snow where the huskies go!

  3. #3
    kmitch80's Avatar
    kmitch80 is offline Junior Member
    Join Date
    Jul 2009
    Location
    alamogordo, new mexico
    Posts
    4

    Re: 95 jeep GC 4.0 stuck in "LIMP MODE"

    well when i changed out the fluid after it started givin me trouble i went and bought 5 qts of ATF+4 and put that in thee transfer case and transmission. after that didnt work i drained it all into a bucket, put the new governor switch and solenoid in and then reused that fluid. But at first i was stuck in 1st, now im in LIMP mode with only 2nd and 3rd. I used to have that problem a few years back in cold weather. But once it would warm up i could turn it off and back on and drive normally. I also learned then that when in LIMP mode, you can get 1st gear if you shift from neutral straight to 1st, then manually shift thru the gears. So its driveable for now, which is good as i use is everyday for work. but not good when its time for me to go to the lake, roughly a 2 hour drive on the highway and would like O/D. Right now starting the jeep the O/D light comes on and in LIMP mode.

  4. #4
    palehawaiian's Avatar
    palehawaiian is offline Junior Member
    Join Date
    Oct 2009
    Posts
    19

    Re: 95 jeep GC 4.0 stuck in "LIMP MODE"

    That really sucks, I have no ideas as transmissions really scare me.. However I just finished putting the whole top end of my motor back on and got to take her on a nice cruise to the beach.... Ah jeaulosy

Similar Threads

  1. What's your "stupidest" or "worst" stuck
    By Craig in forum General Chat
    Replies: 34
    Last Post: 02-15-2011, 10:30 PM
  2. "Check gage" light on 2004 Jeep Grand Cherokee
    By Duke2000 in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 8
    Last Post: 05-04-2009, 05:25 PM
  3. "Invisible Mode"
    By mingez in forum General Chat
    Replies: 10
    Last Post: 12-29-2005, 04:12 PM
  4. Jeep "Patriot" and "Rally" Concepts
    By mingez in forum General Chat
    Replies: 12
    Last Post: 09-06-2005, 08:26 PM
  5. 1997 Jeep Cherokee Sport "Check Engine Light"
    By balloo93 in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 1
    Last Post: 07-20-2003, 07:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in