Search:

Type: Posts; User: tgeej; Keyword(s):

Search: Search took 0.01 seconds.

  1. Replies
    6
    Views
    3,394

    Re: '96 Cherokee Cold Temp Start Issue

    Thanks. I'll post a picture if it's broken.
  2. Replies
    6
    Views
    3,394

    Re: '96 Cherokee Cold Temp Start Issue

    Thanks for checking back on this . . . however . . I think the timing chain just broke. I'm almost to the chain, and should get the cover off tomorrow. Do you, by chance, know if this 4.0 inline 6...
  3. 1996 4.0 inline six Cherokee "Interference engine"?

    I'm pretty sure my 4.0 '96 Cherokee just broke the timing chain, not while under load, but at start. I'm about to dig into it, but I would like to know if this is an "interference engine"?
  4. Replies
    4
    Views
    1,626

    Re: Need to check timing chain or belt on a 4.0?

    I believe my timing chain just broke, and thankfully in my driveway. I have searched for info regarding my concern for further damage if the my '96 inline 6 - 4.0 is an "interference engine", but...
  5. Replies
    6
    Views
    3,394

    Re: '96 Cherokee Cold Temp Start Issue

    After a year with the problem getting worse, and replacing plugs, wires, cap, and rotor, and noting fuel pressure irregularities, I replaced the ECU. Fixed!
  6. Replies
    6
    Views
    3,394

    '96 Cherokee Cold Temp Start Issue

    This winter, my 1996 Cherokee Sport developed a cold temperature start problem. If overnight temps are below 50 degrees or so, the engine cranks just fine but without firing. If I pump the...
Results 1 to 6 of 6

Log in

Log in