1. I have a problem with my camshaft position sensor

    When i rev to 3500rpm it cuts out as if im hitting a rev limiter. It is running i safe mode i believe. So I hooked up a scanner to my jeep and a p0016 reading came back saying camshaft position sensor correlation sensor A.. So lastnight I changed out the CPS but it didnt fix it. After I changed it I hooked up the scanner again and reset the jeep system but soon after it started malfunctioning again.....btw the old sensor had mud on the onside part of the sensor so maybe my distributor is dirt inside the housing for the CPS....... Any ideas?

  2. #2

    Re: I have a problem with my camshaft position sensor

    What year is your jeep? I6 engine?
    Confucious says: Don't eat the snow where the huskies go!

  3. #3
    It's a 2006 4.0

Similar Threads

  1. Throttle position sensor 4.0l s
    By boat567b in forum Wrangler and CJ
    Replies: 4
    Last Post: 04-05-2010, 05:06 PM
  2. Crank Position Sensor
    By JeepMonkey in forum Wrangler and CJ
    Replies: 7
    Last Post: 10-24-2007, 10:12 PM
  3. cam position sensor question....
    By xjjunkie in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 4
    Last Post: 07-31-2005, 07:54 AM
  4. Throttle position sensor?
    By tad in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 10
    Last Post: 03-09-2005, 12:24 PM
  5. Throttle position sensor
    By MudderChuck in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 3
    Last Post: 07-20-2003, 08:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in