1. 2015 rubicon turn signal prob.

    Signal works fine till I turn the headlights on then the left rear stops blinking and the error message comes up on the dash. Its as predictable as death. after it stops blinking I can switch the headlights off but still have the error message and the light still won't blink..UNTIL I can switch the ign. key off and back on and it works fine again till I hit the headlights again...I've checked the light sockets and the plugs at the back...mixed up with the headlight switch some how...anyone had this issue before?

  2. #2
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    5,162

    2015 rubicon turn signal prob.

    No, But clean the grounds for the headlights and blinkers rear blinker ground. If that doesn't fix it. Try pushing into hazards switch a bunch of times. Sometimes dirt gets in and needs to be cleaned.
    And if those do no fix it, swap out the multifunction switch. It is known to go bad. I swapped mine out and had to add some glue to build up the fog switch.


    Regards,
    JPNinPA

    Sent using TapTalk
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  3. #3

    Re: 2015 rubicon turn signal prob.

    Quote Originally Posted by JPNinPA View Post
    No, But clean the grounds for the headlights and blinkers rear blinker ground. If that doesn't fix it. Try pushing into hazards switch a bunch of times. Sometimes dirt gets in and needs to be cleaned.
    And if those do no fix it, swap out the multifunction switch. It is known to go bad. I swapped mine out and had to add some glue to build up the fog switch.


    Regards,
    JPNinPA

    Sent using TapTalk
    ...So anxious for this rain to end so I can give your suggestions a try I also have 3 or 4 others to try too. I have so far changed TIPM, no change, changed multifunction switch, no change. I've heard that it could be: a ground cable from battery to motor or the instrument cluster, prob. ground related also. or maybe the kind of bulbs i'm using, even though it blinks fine without the lights on. if I ever get it figured out i'll post what the fix was.

  4. #4
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    5,162

    Re: 2015 rubicon turn signal prob.

    The headlights and blinkers have a ground on the back of the grill in the engine bay. With engine off, disassemble, clean and polish with fine sand paper and reassemble.


    Regards,
    JPNinPA

    Sent using TapTalk
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

Similar Threads

  1. Replies: 6
    Last Post: 08-12-2019, 09:36 AM
  2. turn signal
    By Scotts cj7 in forum Wrangler and CJ
    Replies: 0
    Last Post: 04-22-2016, 06:43 PM
  3. Turn signal flasher - JGC
    By RUPedro in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 12
    Last Post: 12-11-2011, 05:23 PM
  4. Turn signal problem
    By YJBLUE in forum Wrangler and CJ
    Replies: 1
    Last Post: 06-19-2006, 09:23 PM
  5. turn signal
    By odjeep in forum Wrangler and CJ
    Replies: 6
    Last Post: 04-07-2004, 10:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in