1. #1
    Join Date
    Jul 2021
    Location
    Middle Tennessee
    Posts
    10

    Can anyone tell me......

    What I need sensor wise to "Tune" Up my 1994 4.0 HO? Want all that will balance the fuel air mixture.....She's smelling really rich at idle.
    All the plugs, Wires, Coil are new high performance and from a American manufacturer....Air filter a brand new Wix. Timing was set by an expert...
    And the exhaust is brand new from the head all the way back to the tail pipe, 02 sensor as well.... Still rich.
    Not worried about price, Just want to know the best vendor to go with for the best quality and performance.....Thanks!!!

  2. #2
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    6,128

    Can anyone tell me......

    Any Check Engine Lights? What idle rpms are you at?

    What brand and P/N on the plugs.
    Autolite AP985?
    How about O2 sensor mfg and P/N?

    While you set the general timing the PCM sets the actual timing.

    Is it missing, idling rough or just running rich?

    Clean the TB and IAC. Blow any dirt out of the TPS. Check the temp sensor that goes to the PCM. Fuel pressure.
    Hook up a computer to read the O2 sensors. And any MAP sensor to be sure they are in spec.
    If any sensors get replaced use only OEM parts. Do not throw the old away immediately. Others fail out of the box.

    Run fuel injector cleaner. You could run some steam or seafoam to clean carbon buildup. Check your battery connections and battery health. Every once in a while drive in a lower gear for a mile so the engine goes above 3300 rpm. Above 3300rpm the valves are allowed to rotate. This minimized carbon build up.





    Never look down on anyone unless you are helping them up - Jesse Jackson
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  3. #3
    Join Date
    Jul 2021
    Location
    Middle Tennessee
    Posts
    10

    Re: Can anyone tell me......

    This is a new build, No lights, Idle around 975, And everything fuel wise, Pump....Injectors are new, And I run Lucas Injector cleaner everytime I fuel.
    Pulled the motor apart before installing and hand cleaned all intake ports and intake manifold including the throttle body.
    Buddy of mine who is a meticulous gear head hot rodder said he had never seen a more thorough cleaning. Everything battery is clean, Tight and greased and I only use deep cycle marine batteries
    with copper eye leads on the threaded side posts. The O2 sensor is a new Bosch, I trust them. I'm gonna take your advise and replace all of the sensors and see if that will clean it up.
    Thanks for getting back to me on this.......

  4. #4
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    6,128

    Re: Can anyone tell me......

    Use OEM sensors!!!!! Bosh sometimes causes issues. Idk they just do. Other mfgs fail out of the box.

    975 rpm is high. Should be ~750.

    You may have a vacuum leak. Check your lines and that the intake and exhaust is not leaking.


    Never look down on anyone unless you are helping them up - Jesse Jackson
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in