1. Battery Light and Charging Problems, Please Someone

    Hi, chose to join this site for the fact that im having a huge headache from my girlfriends 99 cherokee, 4.0L 2wd. Symptoms, last week battery light on dash came on and off randomly, finally vehicle died while driving. having small knowledge of vehicles, jumped it, got it to auto parts store had them test alternator battery and whole charging system. First, alternator bad, battery good. got reman alternator, noticed new alternator has sticker saying externally regulated, noticed old alt on vehicle has some sort of capicitor or resistor "added to rear and then wires going into the plug where new alternator says externally regulated. put new alternator in with this "thing" on the rear of alternator and hooked it up just how it was. worked fine for a day. then shut off again. tested again, now battery bad, got new battery. installed worked fine voltmeter checked running 14.05 volts, for half a day then again battery light came on, had auto parts store check charging system, they now say low cranking amps at starter and no amps while running. told me to change all the wires from battery to starter, under hood fuse box, alternator, and grounds. all changed and upgraded to 4 gauge, was prolly 8 gauge previously. worked fine all day today not single problem, driving at night with lights on, battery light comes back on. check with voltmeter engine off battery 12.5 approx. engine running volts 12.35-12.33, rev engine, volts drop to 12.30-12.23. disconnect battery cable while running immediately shuts off. from my experience this is alternator. well im just wondering, im going tomo to get this alt checked and replaced, the wiring to the alternator is B+ main power cord to fuse box and small wire into this resistor, capacitor thing, then green and orange wire comin from fuse box to this "thing" and also spliced into top prong on alt plug where sticker said externally regulated, bottom prong wire goes into this "thing"... green wire that is running near green and orange wire, is cut and only goes back into fuse box. can someone please help or shed some light, i really dont want to keep replacing alternators or what not. also i know about the battery temp sensor and that seems fine. very frustrated at this point and so's the gf.... anyone????? thanks in advance

  2. Find your self the correct alternator. It should have a bulit in regulator.

  3. #3
    Your battery is not being properly charged. I don't think that you need to replace any fuses or wiring, it's pretty much in related to the charging problem. However, make sure that all your ground wires are grounded. Negative battery charge grounded to the engine and the engine to the frame and make sure your starter is also grounded to the engine or the frame. Let me know how it goes.

  4. Re: Battery Light and Charging Problems, Please Someone

    The green wire is supposed to be power in to the field winding, the orange and green wire is to the regulator (in the PCM/computer). It is actually regulated on the ground side in most newer vehicles. Which sounds odd but the electricity doesn't know the difference :). The output of the alternator is regulate by how much power is going through the field windings.
    The Large black and white wire, is the power out, from the alternator to the bus and the battery. There is supposed to be a fusible link between the alternator and the bus connection.

    A quick check for alternator output is to leave the connectors connected, strip back a little insulation on the green and orange and green wires (I use a box knife, careful not to cut into the copper center), check the power from the green wire to ground with the engine running, it should be close to battery voltage. Then check the voltage to ground from the green and orange wire, it should be less than battery voltage with the engine running and nearly the same as battery voltage with the engine stopped. This test works on earlier model XJ's should be the same for yours.

    The alternator is regulated in the PCM, computer.

    Could be your bus connection is loose, there was a TSB for this, but I can't remember the model year.

    This on and off action you are describing sounds like it may be a wiring or connector problem. I don't know what to make of the resistor or capacitor you describe, does it look like it was home grown or done at a dealership (it isn't in the wiring diagram I looked at)?
    A capacitor normally looks like a small tin can, a resistor is usually ceramic and has colored stripes on it. Resistors burn out, condensers short to ground. A condenser is rarely necessary for function, disconnecting them seldom hurts anything besides sometimes wearing out a relay a little quicker or maybe a little noise on your radio. Is it possible what you are looking at is the fusible link? I sure don't know where the fusible link (in line fuse) is located on the 99.
    Last edited by MudderChuck; 03-19-2011 at 08:41 AM.
    DO IT IN THE MUD!

  5. Re: Battery Light and Charging Problems, Please Someone

    Found this, may be helpful :).

    DO IT IN THE MUD!

  6. #6

    Re: Battery Light and Charging Problems, Please Someone

    i will try to get pictures of this home grown looking thing, i also read it might be a signal strengthener for am radio or something. where are the green and orange wires suppsed to go on the alternator? all i have on back of alternator is B+terminal and then a 2 pin female plug. there is no ground, assuming the ground is the casing. and the starter is grounded to the vehicle through the housing is it not??

  7. #7

    Re: Battery Light and Charging Problems, Please Someone

    and to make things easier can someone tell me where exactly the green wire, and the green and orange wire are supposed to go??? are they supposed to have a plug on the end of them that plugs into the alternator? if so, from top of vehicle which one goes on top side and which one is on bottom?

  8. #8

    Re: Battery Light and Charging Problems, Please Someone


    GENERATOR - BLACK 2 WAY CAVCIRCUIT FUNCTION(1)K72 16DG/OR GENERATOR DRIVER(2) K20 18DG GENERATOR FIELD DRIVER (-)
    By looking at the plug orientation vs. the alternator , you should be able to determine which wire goes where if there's no number on the back of the alternator.
    Confucious says: Don't eat the snow where the huskies go!

  9. #9

    Re: Battery Light and Charging Problems, Please Someone

    thanks alot for that picture. so whatim understanding is dk gr is negative and dk gr/or is a positive? my dark green/orange is pulling in 12.4 volts while engine running, no volts with engine off, but the dark green is disconnected....

  10. #10

    Re: Battery Light and Charging Problems, Please Someone

    so just went back out there and now this is not making any sense, dark green/ orange wire while engine running is a positive 12.4 volts. shut engine off and it is now a negative 12.5 volts... wtf. the dark green wire is negative 12.2 running negative 12.15 while off. i now believe this "thing" on the back of the alternator is an external regulator... but i believe all this wiring is wrong.... this is racking my brain

  11. Re: Battery Light and Charging Problems, Please Someone

    The book says the dark green should be near battery voltage with the engine running and the ASD relay energized, voltage into the field windings. You can test this at the green wire disconnected from the alternator. That thing you are looking at is doubtful to be an external regulator, more likely the fusible link. Disconnect one end and do an ohm test to the other end after stripping back a little insulation, should be zero ohms.
    What you are reading on the orange and green wire is likely residual voltage from the regulator/driver, it said in the book it is a pulse regulator.
    Check your meter and make sure it is switched to DC and not AC and your leads are plugged into the proper holes and the battery is good (if it is a digital).
    Might as well do an ohm test from the alternator case to the battery negative while your down there. I've seen alternators and starters refuse to work because they are covered in oil and are making a crappy ground (though I doubt this is your problem).
    They make internally regulated Denso alternators, that look just the same as the externally regulated alternators on the outside, except for the connections. It's possible somebody stuck an internally regulated Denso in there and cut the regulator wires. Maybe the regulator in the PCM crapped out and installing an internally regulated Denso seemed a cheaper solution than a new PCM, anything is possible. Though it is likely is this were the case, the check engine light would stay on all the time.
    Make sure the ignition switch is off before you connect or disconnect anything, flashing the PCM is supposed to be a regulator killer.
    DO IT IN THE MUD!

  12. #12

    Re: Battery Light and Charging Problems, Please Someone

    i have a picture of this "thing" but have no clue how to put it in here, its not like other forums where you can drag and drop but anyways i was out there messing around with it and following that plug diagram i did a plug and pray lol i totally disconnected this "thing" connected B+ from the proper location, hooked up the dk green and dk gr/orange to the according pins thanks to the earlier diagram of the plug. plugged everything back in, started her up, started fine, moment of truth, put the dmm on the battery and she has 13.9 +/- volts while running!!! took her down the street with no problems so far.... also, there is absolutely no fusible link going to alternator, i changed all the power wires and noticed one that look to be joined with a plastic sleeve on it, so stripped the sleeve and its just where the wires are connected no fuse no smaller wires.... have i done something wrong? will be going to autozone later to ask them to run a charging test for me to make sure amps and what not are right. crossed fingers, but shes running fine now.... oh and even tested with engine running, headlights and a/c running and it ran around 13.1 volts.... is all safe and good to go???? did we do it???

  13. #13

    Re: Battery Light and Charging Problems, Please Someone

    I figure you'd let us know if it blows up. So you would have to let us know the answer to that question, good to go?
    Confucious says: Don't eat the snow where the huskies go!

  14. #14

    Re: Battery Light and Charging Problems, Please Someone

    well just wanted to give the update. as of yesterday afternoon around 4pm and all the running around about 200 miles in that time the light has not come back on. and just as an assurance yesterday on way to her house i took it in to autozone and did a charging system test and everything checked out great. so the problem was, the "thing" lol which is now believed to be an external regulator someone had put on previous to kattie owning the vehicle. anyways everything hooked back up to factory wires and is running great, so just wanted to thank everybody for the help and advice that was given, it guided me into getting it fixed. much appreciated everyone :)

Similar Threads

  1. 1998 Jeep Cherokee Not Charging Battery
    By skate14 in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 38
    Last Post: 06-24-2021, 01:19 AM
  2. European Cherokee, Serious charging problems :(
    By scottishcherokee in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 2
    Last Post: 03-25-2009, 05:16 AM
  3. Tightened belt, battery not charging
    By IRPancake in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 4
    Last Post: 09-20-2008, 11:48 AM
  4. 91 Jeep Cherokee battery light problem!
    By jaspercomp in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 5
    Last Post: 03-25-2005, 01:28 AM
  5. Battery problems
    By Beach_Jeep in forum Wrangler and CJ
    Replies: 2
    Last Post: 05-09-2004, 01:11 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in