Page 1 of 4 123 ... Last
  1. #1

    Question to all you Jeep Experts?

    2004 TJ, 4.0, Auto, A/C. 20500.0 miles.
    Ongoing issue ( 6 year+) when engine is hot, when restarting will intermittently throw a 303 code ( number 3 cylinder misfire ).

    Over the years I have replaced Spark Plugs, OPDA, Coil Pack, Fuel Injectors, Fuel Pressure Regulator, Duty Cycle Purge Solenoid. Problem still persists.

    Recently a new issue has developed. While traveling down the highway. 65 MPH, A/C on, loss of power and Engine Temp red lines.

    Pull over, shut down, sit for 20 minutes or so, restart, all good.

    A/C seams to aggravate the issue. Drove 200 miles freeway, no A/C, issue free same day.

    After reading up on the PCM I'm thinking I could have a bad Coolant Temp Probe? A bad MAP probe, bad Intake Air Temp Probe?

    All three of these items send info to the fuel metering process?

    Chasing intermittent issues is a pain in the butt!

    Has anyone experienced issues like this? Any suggestions are greatly appreciated !

    Thank you,
    Andrew~
    [IMG]DSC01433.JPG[/IMG]

  2. #2

    Re: Question to all you Jeep Experts?

    not i but i hope you are able to fix it
    03 rhd tj

  3. #3

    Re: Question to all you Jeep Experts?

    Anything and everything can be fixed! I'm sure someone, somewhere has experienced similar issues! I'm not that special!! :)
    [IMG]DSC01433.JPG[/IMG]

  4. #4
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    6,610

    Re: Question to all you Jeep Experts?

    First. Use only OEM sensors…
    If not you will be introducing new issues snd chasing fireflys.

    303 on restart is the heat evaporating gas in the line right at injector #3.
    Place heat shield in the intake and get a heat shield for injector #3.
    Amazon.com


    Never look down on anyone unless you are helping them up - Jesse Jackson
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  5. #5
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    6,610

    Question to all you Jeep Experts?

    Temp could be several issues.
    When the pcm sees >215 it goes to full scale and limp mode. So if it is216 it will still show full scale and limp.

    What RPm do you idle at?
    When at temp what is the temp reading? ~205 or ~215…
    Is the temp suddenly jumping or steady climb?

    Is the radiator topped off?
    Is there oil in your water or water in your oil?
    From cold




    Never look down on anyone unless you are helping them up - Jesse Jackson
    Last edited by JPNinPA; 09-04-2022 at 09:50 PM.
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  6. #6

    Re: Question to all you Jeep Experts?

    Radiator is topped, system purged,
    Temp runs steady ~215~
    When it goes hot, it climbs rapidly.
    Just did a oil change, no sign of water in the oil
    No sign of oil in the coolant.
    Do you want idle RPM with A/C on or A/C off?

    I don't think it's triggering the limp mode. If it did would there be a code showing that action?
    [IMG]DSC01433.JPG[/IMG]

  7. #7
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    6,610

    Question to all you Jeep Experts?

    Both rpm idle a/c no ac. And what rpm are you at when going 65?

    The PCM goes into limp mode when the temp goes above 215. Its actually the pcm that makes the readout jump. No code will show but the engine light will flash. Check temp will show in the odometer.
    First issue:
    It should run just under210. A 195 deg thermo gives a 210 reading.
    You should be able to maintain 210 above 30 mph. Without the fan needing to kick on.
    Second is possibly a bad clutch fan.
    Air in the system will cause temp spikes but that would happen with or without the a/c.
    Also check your radiator fins. You should be able to see through. If mud or leaves pack it you do not get yhe same cooling.


    Did you change anything in the cooling system?
    Radiator
    Overflow
    Cap
    Water pump
    Clutch fan
    Belt
    Thermo
    High-flo neck….



    Never look down on anyone unless you are helping them up - Jesse Jackson
    Last edited by JPNinPA; 09-04-2022 at 09:51 PM.
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  8. #8

    Re: Question to all you Jeep Experts?

    Radiator is about a year old OEM. Have been running an electric fan for years issue free. replaced the belt a few thousand miles ago, installed new Harmonic Balancer. OEM. I "think" I am running a 210 thermostat because the 195 would cause daily code that it was taking to long to get to operational temp range. The computer is looking for a warm temp within a dedicated time line. Radiator is clean, good air flow.
    Cap is OEM, overflow OEM, water pump a few thousand miles ago.

    As for the RPM's, I'll get those when I'm back in Florida. Mid October. I'm back in Hawaii doing some consulting.
    I'll arrive in Florida to a stack of new replacement parts!

    Thank you for your thoughts, keep them coming.

    Andrew~
    [IMG]DSC01433.JPG[/IMG]

  9. #9
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    6,610

    Question to all you Jeep Experts?

    Quote Originally Posted by Andrew Mac View Post
    I am running a 210 thermostat because the 195 would cause daily code that it was taking to long to get to operational temp range. The computer is looking for a warm temp within a dedicated time line.


    Andrew~
    You need a 195 deg thermo. It is what the engine is designed to run at. At higher temps you run the risk of internal boiling and overheating. The piston walls warping and exhaust valves melting from the heat. You might note pinging or knocking under loads.

    What was the daily code? Ive run with a failed open thermo and no codes. It just took 5 mi suburb driving to get to temp vs 2 mi.

    Is the radiator really OEM. Cause OEM has a higher fin density than other OEM like radiators. And provides better cooling.

    Was the water pump a high flow or non OEM?

    What electric fan are you running and is it hooked into the AC to kick on when the AC is running?

    As for driving RPM do you recall what tire size, trans and rear ratio?? Then rpm at65 can be calculated.


    Is your heater core connected and if so is it blocked? Easy check is do you get good hvac heat when engine is at temp.



    Never look down on anyone unless you are helping them up - Jesse Jackson
    Last edited by JPNinPA; 09-01-2022 at 07:57 AM.
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  10. #10

    Re: Question to all you Jeep Experts?

    Tire size is 33" Automatic Trans, stock gearing, I think 65mph is 1800-1900 RPM?
    The fan is Hard wired and operates when ignition is on. I did that since I live in warm climate areas!
    Heater core is new, works well.
    Water Pump is OEM.
    The Radiator is OEM, Mopar .
    I've ordered a 195 deg thermostat!
    [IMG]DSC01433.JPG[/IMG]

  11. #11
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    6,610

    Re: Question to all you Jeep Experts?

    So what fan? Make & model??
    Is it a pusher or puller?


    For thermo i usually buy Stant with the bleeder. I stay away from any fail safe model because they do not last.


    Never look down on anyone unless you are helping them up - Jesse Jackson
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  12. #12

    Re: Question to all you Jeep Experts?

    Fan is a Mishimoto MMFS-WRA-87 from Carid Has worked well for 2 years. Puller
    I purchased a Mopar thermostat.
    [IMG]DSC01433.JPG[/IMG]

  13. #13
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    6,610

    Question to all you Jeep Experts?

    That fan moves 1850 cfm.
    Many posts state 2000cfm is minimum and barely sufficient. You must have a shroud too. Without one the fan is pulling air around and not through the radiator.

    Tarus fan is 2500 and 4000 cfm

    Flex a lite black magic 485 3300cfm

    I run the 485 with no issues. I use their controller. Only kicks on when below 30 mph for a short period. When it does kick on you could see the temp needle move from 210 down to ~208 fairly quick.


    Never look down on anyone unless you are helping them up - Jesse Jackson
    Last edited by JPNinPA; 09-03-2022 at 07:53 PM.
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  14. #14

    Re: Question to all you Jeep Experts?

    Flex a lite black magic 485 just ordered!
    [IMG]DSC01433.JPG[/IMG]

  15. #15
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    6,610

    Question to all you Jeep Experts?

    Another question. Do you have anything blocking the radiator? Wench or grill blackouts?
    At 65 mph the force of air should cool sufficiently. Actually at ~35 mph the force should be sufficient.

    With the 485 get a high watt relay and inline 40A fuse. The starting current of the 485 is ~31A momentarily. At least that is what i measured. Use a temp controller. I used theirs. You do not want it running constantly. It will kill your battery.


    Never look down on anyone unless you are helping them up - Jesse Jackson
    Last edited by JPNinPA; 09-03-2022 at 08:45 PM.
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  16. #16

    Re: Question to all you Jeep Experts?

    Nothing blocking the radiator, Will wire in a 40A fuse and relay. What does their temp controller tie into?
    I still don't think this is the issue I am chasing. The latest over temping was at highway speeds! No trailer, just cruising along!
    I'll feel better with the better fan installed.
    [IMG]DSC01433.JPG[/IMG]

  17. #17
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    6,610

    Re: Question to all you Jeep Experts?

    Is your icon pic your ride? If so you have a wench blocking your radiator.

    You could download their wiring diagram. Direct-fit Black Magic X-Treme electric fan for 1987-2006 Jeep Wrangler


    Never look down on anyone unless you are helping them up - Jesse Jackson
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  18. #18

    Re: Question to all you Jeep Experts?

    Correct, there is a winch out front, it's been on there for 10+ years no issues! Temps have always run normal.
    [IMG]DSC01433.JPG[/IMG]

  19. #19
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    6,610

    Question to all you Jeep Experts?

    Well maybe. But it is something in front of the radiator disrupting airflow and pressure.
    Others have found the same, wench has block air flow causing-overheating.
    Looking at the Mishimoto MMFS-WRA-87, the shroud has no depth And is close to the radiator. So my assumption is there is only good flow at the opening.


    BTW each time your temp spikes does your radiator bubble over into the expansion tank?
    It should. If not your radiator will Grenade. after each overheat you should check fluid levels when its cold. Cap is 18 psi stant.


    Never look down on anyone unless you are helping them up - Jesse Jackson
    Last edited by JPNinPA; 09-04-2022 at 09:35 PM.
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  20. #20
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    6,610

    Re: Question to all you Jeep Experts?

    And nothing like these in the grill?
    Question to all you Jeep Experts?-image1662342321.731695.jpgQuestion to all you Jeep Experts?-img_3975.jpgQuestion to all you Jeep Experts?-img_3977.jpg


    Never look down on anyone unless you are helping them up - Jesse Jackson
    Attached Thumbnails Attached Thumbnails Question to all you Jeep Experts?-image1662342362.338313.jpg  

    "Never look down on anybody unless you're helping him up" - Jesse Jackson

Page 1 of 4 123 ... Last

Similar Threads

  1. Anyone brake experts?
    By Wrangler11 in forum Illinois Jeep Forum
    Replies: 3
    Last Post: 11-03-2011, 06:44 PM
  2. Experts help b4 she blows!!!!
    By blue94yj in forum Wrangler and CJ
    Replies: 4
    Last Post: 01-07-2004, 01:58 AM
  3. I need some XJ Experts Opinion!
    By 80CJRenegade in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 5
    Last Post: 09-30-2003, 12:28 AM
  4. Experts, help with vehicle identification
    By TerryMason in forum Wrangler and CJ
    Replies: 3
    Last Post: 07-20-2003, 08:00 PM
  5. Few Questions for Jeep experts!
    By jeepster in forum Wrangler and CJ
    Replies: 7
    Last Post: 07-20-2003, 08:00 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in