1. 2004 Liberty won't start after running 45 minutes - HELP

    Hi Guys - hopefully someone has some idea what's going on because I am stumped.

    My 2004 Liberty starts on a cold engine no problem, if I take a short drive and stop the engine, same thing. However when I have been driving about 45 minutes, if I turn the engine off - it won't turn over and instead starts giving me light white smoke. If I leave it for 20 minutes or so, it will start right up.

    Will add at no point does the engine get hotter than normal.

    Any ideas are much appreciated!

  2. #2
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    5,654

    2004 Liberty won't start after running 45 minutes - HELP

    Describe the “light white smoke”
    Where is it coming from?
    Is there any smell?
    If under the hood, open it and let someone else start it to find where the smoke is from.

    By your description I’d think the smoke is from the battery, alternator or starter.


    Any CEL or codes?

    Never look down on anyone unless you are helping them up - Jesse Jackson
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  3. Re: 2004 Liberty won't start after running 45 minutes - HELP

    Check your fuel pressure also.

  4. #4

    Re: 2004 Liberty won't start after running 45 minutes - HELP

    Quote Originally Posted by JPNinPA View Post
    Describe the “light white smoke”
    Where is it coming from?
    Is there any smell?
    If under the hood, open it and let someone else start it to find where the smoke is from.

    By your description I’d think the smoke is from the battery, alternator or starter.


    Any CEL or codes?

    Never look down on anyone unless you are helping them up - Jesse Jackson
    ____

    Thanks! The smoke is form under the hood but we can't work out where it's coming from. There's no strong smell, it gets worse the more i try to start it - It's got a new battery as of last week, I changed it when it first happened thinking that was the prob, I had figured it was the starter but couldn't work out why it starts no problem when cold!

  5. #5
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    5,654

    Re: 2004 Liberty won't start after running 45 minutes - HELP

    !!!You need to work out that smoke!!!
    Fire may be next.
    Check the wires. Battery ground to chassis and to engine. Positive from alternator and to starter.
    You may have a bad connection or corroded wire.


    Never look down on anyone unless you are helping them up - Jesse Jackson
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  6. #6
    Join Date
    Feb 2009
    Location
    Dayton Ohio Area
    Posts
    5,654

    Re: 2004 Liberty won't start after running 45 minutes - HELP

    I had an F150 that the brushes on the alternator wore down to where they would intermittently short.
    The sign was the battery voltage indicator on the panel would fluctuate.
    If i turned the engine off when it did this, it wouldn’t start.
    Killed 2 batteries before i figured it out.


    Never look down on anyone unless you are helping them up - Jesse Jackson
    "Never look down on anybody unless you're helping him up" - Jesse Jackson

  7. #7

    Re: 2004 Liberty won't start after running 45 minutes - HELP

    Quote Originally Posted by JPNinPA View Post
    I had an F150 that the brushes on the alternator wore down to where they would intermittently short.
    The sign was the battery voltage indicator on the panel would fluctuate.
    If i turned the engine off when it did this, it wouldn’t start.
    Killed 2 batteries before i figured it out.


    Never look down on anyone unless you are helping them up - Jesse Jackson
    ___
    Super helpful, thank you! I will check out the alternator.

Similar Threads

  1. 2004 Jeep Grand Cherokee won't start (or start to turnover)...
    By richdemarco in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 8
    Last Post: 09-05-2019, 02:38 PM
  2. 2004 Jeep Grand Cherokee Laredo, alternates running great with running rough
    By DJM in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 5
    Last Post: 06-25-2019, 08:54 PM
  3. 2004 Liberty Headlamps flashing
    By Randall in forum Jeep Electronics and Audio
    Replies: 7
    Last Post: 07-07-2017, 01:37 PM
  4. Liberty continually running hot
    By jberg25 in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 2
    Last Post: 01-15-2015, 12:09 AM
  5. 2004 Jeep Liberty... new user needs help...
    By maine1963 in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 10
    Last Post: 10-14-2009, 10:40 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in