500 Error On Resgistration Page


New member
Tried to sign up a few weeks ago but couldn't. My browser didn't display an error. There's no output in viewsource.

Tried again yesterday and had the same response.

So I tried Chrome on a different box and saw a 500 error..

I saw the link "Download Our App", so I installed that on my phone, then regestered, then came back to the site and was able to log in.

I used the search feature to see if anyone else had already posted about the error but didn't find anything.

A 500 error is usually a config error, but can also be a permissions error (I'm a server admin / programmer by trade).

If you're running nginx, make sure the path block allows php-fpm. If it's apache make sure php is allowed to run in that directory (add "+" to dir block <..> in apache config).

Lastly you can change the perms to 755 to test (chmod 755 /path/to/register.php -or- chmod +x /path/to/register.php). Test by logging into the server and running php against the page (php /path/to/register.php).

Make sure the "owner" of register.php is whatever webserver you're running (eg: chown apache:apache /path/to/register.php).

If it's IIS (a windows server), switch to a Linux or Unix server :).

I heard great things about this forum, but the inability to register here made me register on a different forum. That sucked as you'd expect so I came back to get it figured out. I'm in now, so no biggie, but it may be keeping others from being able to sign up!!

I just wanted to say thank you for posting this. I hadn't tested the registration process for a long time, and it appears that a previous upgrade to PHP caused some stuff to break. It should now be resolved.

As a side note, the error_log had grown to 25 gigs....
No problem!

Dang! 25 gigs - that's crazy!!

Just curious, do you mean it was it a single file?

(logrotate should split them out by day, but it may not be running in cron)

If it was the directory that filled up, I could write something in bash to run once a week, check the dir size, and if over some amount you set, remove oldest first till under the limit. That way you don't have to log in. I can just post the script here, so you can confirm with others it's not sketchy.

Come to think of it, logrotate may already have that ability...

Not sure how your set up, but ruining out of physical space may cause issues with swap - and your db.

I can't tell if this stuff is stuff you're already aware of - if so, just disregard!!

Love this phone app!! Very convenient!

Sent from my garage using Jeepz.com mobile app
This file isn't managed by logrotate. I've actually started looking into this more and killing the errors that are filling up the log. The reality is that I need to deal with these problems now to prevent this from happening again.

We didn't run out of space, it's just that there were so many warnings (i.e. trying to use mysql connect with php 7, etc) that the real problems got lost in the noise.

Ahh yes, that's the right strategy.

I believe it's mysqli_ with ($connection, statement) now.

You aren't using mariadb? That should be what's in the repos nowadays.

PHP is my favorite language to write in..been thinking about writing a forum 'cause I get so frustrated with the ones out there now - their either too heavy, poorly organized or poorly written - or all of the above lol

Sounds like you got this!

Sent from my garage using Jeepz.com mobile app