1. #1

    Electrical Issues

    I've got a 99 Jeep TJ. My instrument cluster doesnt light up when I turn on my headlights on. I can get the cluster to light up when I work the light knob between full on and off. When they do light up, the engine shutters along with the radio....any help out there?

  2. #2

    Re: Electrical Issues

    Welcome to Jeepz. Either there's a short to ground on the illumination circuit on the dimmer to cluster and radio or there's a bad connection on the back of the cluster thats affecting the communications line when the cluster lamps gets the full voltage. Do a process of elimination. Do you have an aftermarket radio installed?, disconnect the radio from the electrical connector and see if it still has the symptom. If not, check the connections on the back of the cluster for oxidation on the terminal pins. A magnifying glass will sometimes help in locating the oxidation on the affected circuits.
    Confucious says: Don't eat the snow where the huskies go!

  3. Re: Electrical Issues

    Look at the odometer when this happens and tell me if it says this:
    no bus

    If it does I know what it is. Just try that out.

Similar Threads

  1. Electrical issues -- '03 Rubicon
    By keyszach in forum Wrangler and CJ
    Replies: 7
    Last Post: 04-11-2009, 11:58 AM
  2. Electrical Help
    By wrenchhead423 in forum Wrangler and CJ
    Replies: 7
    Last Post: 02-19-2009, 05:24 PM
  3. electrical help?!
    By cresencio in forum Wrangler and CJ
    Replies: 2
    Last Post: 12-25-2008, 03:15 AM
  4. related electrical issues?
    By Nomad in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 1
    Last Post: 11-20-2008, 05:01 PM
  5. 258 85cj7 am I having timing issues or valve issues
    By Platsmith in forum Wrangler and CJ
    Replies: 1
    Last Post: 07-03-2004, 05:26 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in