1. 2.5L Eng Missing at speed/Intermittent

    Warm Engine Missing, Intermittent

    Okay, I need some suggestions before I go into the shop again (that is if it doesn't heal itself on it's own). I have a 94 YJ w/2.5L 4 banger. 131K miles. I just had a new head installed. New Plugs, Cap, Rotor, Coil, Fuel Filter, oxygen sensor. TPS Adjusted, throttle Body Cleaned. Cool Air Intake kit installed. The jeep runs fine until it gets warmed up. Then it "misses" (Shudders)at acceleration and cruzing speed. (It does not stall, idle is smooth and only backfired once) Mostly but not always this happens at around 2500 to 3000 rpms. It's acting as if the timing is off just a little so that it won't take the fule at those few occasions when this happens. Do any of you wise folks have an idea what to check next? PS: The head, plugs and TPS was done first by a shop then I did the rest over about a month with no effect as each was done. I probably should start over and check the plugs unless you have other suggestions.
    Aaron

  2. #2

    Re: 2.5L Eng Missing at speed/Intermittent

    My guess would be Catalytic converter or some type of exhaust obstruction. Since you just had all this work done and that it only happens at speed and not at idle.

    Good luck
    It used to be a jeep Thing,
    But all that stuff broke

    -Johnny-


  3. #3

    Re: 2.5L Eng Missing at speed/Intermittent

    X2. Usually at it's worst, after warm up, it wont go above 2500rpm..
    Confucious says: Don't eat the snow where the huskies go!

  4. #4

    Re: 2.5L Eng Missing at speed/Intermittent

    Thanks, I'll see if I can find a Cat By-Pass tube and see if it does it with the converter removed. It was burning some water with the bad head. There was rust in the #1 Cyl. Aaron

  5. #5

    Re: 2.5L Eng Missing at speed/Intermittent

    Could be an injector problem, put a long prybar or dowel on each injector to make sure they all sound the same. I just went through this and it was an injector even though it behaved as a spark problem.

  6. #6

    Re: 2.5L Eng Missing at speed/Intermittent

    Thanks! I'll give that a try too. Aaron

  7. #7

    Re: 2.5L Eng Missing at speed/Intermittent

    This sounds quite similar to my issue. Very intermittent. sometimes I can go days with no problem and other times I get to where I want to drive it off a cliff. It will do it at most speeds but the faster I go the less it happens. Makes driving around town a pain. 25 - 45 mph seems to be the worst. at, say 35 mph, steady speed, the vehicle feels like is is starting to slow down, a seat of the pants sense. The engine sounds ok when it does this. But a moment later it sounds like someone put their hand over the air intake on the throttle bodyand I loose all power. If I do not move the accelerator, it just keeps slowing down. If I let off the accelerator or step on the accelerator it recovers.

    1990 YJ w/2.5l & 5sp

Similar Threads

  1. Intermittent Wipers, Directionals, and Radio
    By Gemini79 in forum Wrangler and CJ
    Replies: 2
    Last Post: 12-16-2009, 04:17 PM
  2. intermittent rough idle
    By Chip682 in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 3
    Last Post: 04-07-2009, 07:22 AM
  3. Intermittent No Start
    By avyoung in forum Wrangler and CJ
    Replies: 6
    Last Post: 01-26-2004, 07:42 PM
  4. Intermittent Rough Idle when Hot - 95 JGC 5.2L
    By willys in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 1
    Last Post: 07-20-2003, 08:00 PM
  5. Intermittent Wipers snowstorm
    By sigmund79 in forum Cherokee, Commander, Wagoneer and Liberty
    Replies: 1
    Last Post: 07-20-2003, 08:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in